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Preface

Purpose of this book
This Getting Results book provides you with information on how to install and 
navigate the RSLogix 500 software. This guide includes troubleshooting 
information and tips on how to use RSLogix 500 effectively. It also explains 
how to access and navigate the online help.

Intended audience
We assume that you are a control engineer familiar with:

IBM-compliant personal computers
Microsoft Windows 98®, NT 4.0™, or Microsoft Windows 2000™ or
Windows XP™

Rockwell Automation’s SLC 500™ and MicroLogix™ families of controllers

Document conventions
This manual uses the following typographical conventions:

[Bold] characters in brackets represent keystrokes used to execute a 
function. When more than one key is to be pressed at a time, the keys are 
separated by a plus sign. For example, [Ctrl + v] means hold down the 
[Ctrl] key and press the [v] key.
Bold characters represent menu choices.
TEXT IN THIS FONT represents characters that you should type.

Online help
If you need help while using RSLogix 500, use any of the following methods:

choose Help from the menu bar
click the Help button on any RSLogix 500 dialog
press [F1] on any instruction, dialog box, or window view.

For more information about the online help refer to RSLogix 500 online help on 
page 73.
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Training
Rockwell Software offers both classroom training and a computer-based 
training program for RSLogix 500 software. For more information see RSLogix
500 Training on page 77.

Commonly used terms
The following table defines terms commonly used in this book. 

This term: Represents this concept:

activation files Hidden files in the root folder that allow the software to run. The 
software checks for these files before you have access to offline 
or online programming

back up To make a copy of the current file before replacing that file with 
an updated version. 

download Restore a specified file to a specified processor. For example, 
when you download the current project file, you copy the file to 
a specified processor so the processor can begin running that file.

library A file into which you store or from which you retrieve portions 
of ladder logic.

mnemonic A term, usually an abbreviation that is easy to remember. SLC 
instructions are typically represented by a 3-letter mnemonic.

project All of the files that make up the SLC 500 logic program including 
the documentation files.

upload Access an SLC processor and save a copy of the project. 

verification An analysis of the ladder program files that results in the display 
of any programming errors.

zone Portion of the ladder logic identified by a marker indicating the 
edited state of the file.
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Introduction
This chapter explains how to install and start RSLogix 500 software. This 
chapter includes information on the following:

system requirements
installation methods
activation overview and methods
installation and activation procedures
starting procedures
troubleshooting installation and activation

After installing the software, we recommend that you read the release note 
located in the online help. The release note may contain more up-to-date 
information than was available when this document was published. To view the 
Release Notes, start the RSLogix 500 software; then choose Help > RSLogix 
Release Notes.

System requirements
To use RSLogix 500 effectively, your personal computer must meet the 
following hardware and software requirements:

Hardware requirements
an Intel Pentium II® or greater microprocessor
128 MB of RAM for Windows NT, Windows 2000, or Windows XP 
installations (64 MB for Windows 98® installations)

Chapter Installing RSLogix 500

Important If you are installing RSLogix 500 on a computer running Windows 
NT®, Windows 2000™, or Windows XP™, you must have 
administrator privileges for the computer.  For more information, 
contact your system administrator.
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45 MB of available hard disk space – 115 MB if you are installing the source 
control feature (available in the Professional edition) 
256-color SVGA graphics adapter with 800x600 resolution
a CD-ROM drive
a 3.5-inch, 1.4 MB disk drive (required only for activation, therefore, it is not 
required on client machines in a client-server installation)
any Windows-compatible mouse or other pointing device

We recommend a 500-MHz Pentium computer with 128MB RAM or greater 
for optimal performance.

Software requirements
The operating system must be one of the following:
Microsoft Windows 98
Microsoft Windows 2000
Windows NT 4.0 with Service Pack 6 or greater.
Windows XP
RSLogix 500 will not run under Windows 3.1, or Windows for Workgroups 
using the 32-bit extensions to these environments, versions of Windows NT  
operating systems earlier than 4.0, or Windows 95® operating systems.
RSLogix 500 relies on RSLinx™ communication software, version 2.31.00 or 
later.  One copy of the RSLinx Lite software in included with the RSLogix 
500 software. 
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Activation

All Rockwell Software products are copy-protected, allowing only a computer 
with access to an activation key the ability to run the software. The activation 
key is located in an activation file, which is originally located on the Master disk 
supplied with the product. The activation file contains one activation key per 
product. Each activation key contains one or more licenses, depending on the 
number of copies of the product you have purchased.

During installation, follow the instructions that appear on the screen to move 
the activation file from the Master disk to the root folder of the drive on which 
you're installing the software. 

Installing RSLinx Lite software
If you have RSLinx

2.10 or later
installed, you do

not need to install
RSLinx Lite.

RSLinx Lite provides communication between the programmable controller 
and a personal computer.
To install RSLinx Lite software: 
1. Insert the RSLogix 500 CD-ROM into the CD-ROM drive.  The 

installation program should start automatically.  If it does not, open the 
installation disk with Windows Explorer and run SETUP.EXE.

2. Click Install RSLinx Lite.
3. Follow the directions that appear on the screen.
When the installation is complete either click Exit on the CD-ROM menu or 
install RSLogix 500. 

Tip You can find a great deal of information about how software 
activation works in Appendix A, starting on page 81.

Tip Store your Master disk in a safe place. If your activation becomes 
damaged, the Master disk may be the only means to run your 
software in an emergency.

Important Do not install activation on RAID or mirrored drives. You could 
lose the activation.
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Installing and activating RSLogix 500 software

Security Server users: If you intend to use Security Server with RSLogix 500, 
you must have a working and configured Security Server before attempting to 
run RSLogix 500. Carefully read the warnings that appear on the screen before 
continuing with Security Server installation!
To install and activate RSLogix 500 software, perform the following steps:
1. Insert the RSLogix 500 CD-ROM into the CD-ROM drive.  The 

installation program should start automatically.  If it does not, open the 
installation disk with Windows Explorer and run SETUP.EXE.

2. Click Install RSLogix 500.
3. Follow the instructions that appear on the screen.

Serial number. When asked for the serial number, you can find this 
information on the box your software came in. 
Changing the folder. The default installation folder is C:\Program 
Files\Rockwell Software\RSLogix 500 English. If you wish to install the 
software to a different location, choose the Custom setup type. Click 
Change to change the drive or folder. Installed features default to those of 
the Complete setup. For additional help with the Custom setup, click the 
Help button.
Activation. When prompted to install activation, insert the Master disk into 
the 3.5-inch disk drive. Follow the instructions that appear on the screen 
to move the activation file from the Master disk to the computer’s hard 
drive.

4. When you are finished installing and activating the software, remove the 
RSLogix 500 CD-ROM and the RSLogix 500 Master disk from the drives. 
Store them in a safe place. 

Tip While installing RSLogix 500 software, you will have the 
opportunity to specify the folder into which you want to install the 
software. The default folder is:
x:\Program Files\Rockwell Software\RSLogix 500 English
(or RSLogix 500 Pro English)
We recommend that you use the default folder whenever possible.
In procedures that appear throughout this document, we assume 
that you used the default name. If you did not use the default name, 
substitute the actual name you specified for the default name 
shown.
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Installing the source control feature

The source control feature of RSLogix 500 can help you manage your projects.  
This feature creates a library of projects.  Users can “check out” projects to 
work on them, and check them in when their changes are complete.  The source 
control feature keeps track of these changes, noting who changed the projects.  
You can also “roll back” a project to any previously checked-in version.
For information about configuring and using the source control feature, see 
Chapter 9, Source control.

Installing the Microsoft SQL Server Desktop Engine
The source control function requires that you install the Microsoft SQL Server 
Desktop Engine (MSDE).  MSDE is a version of SQL Server 2000 that runs in 
a standalone mode.

To install MSDE:
1. Insert the RSLogix 500 CD-ROM into the CD-ROM drive.  The 

installation program should start automatically.  If it does not, open the 
installation disk with Windows Explorer and run SETUP.EXE.

2. Click Install Source Control.
3. Click Install SQL Server Desktop Engine.  The MSDE installation 

starts.
4. The MSDE installer shows a dialog showing the progress of the 

installation.  When the installation completes, this dialog closes.
5. Reboot your computer (you must reboot to start MSDE).

Tip The source control feature of RSLogix 500 requires that you run the 
software under Windows 2000 or Windows XP.
The source control feature is a standalone version of the RSMACC 
Archive module.  Do not install the source control feature if you are 
using the RSMACC Archive module.

Important If you already have an instance of Microsoft SQL Server 2000 
installed on the computer, do not install MSDE.  The source control 
feature will function with SQL Server 2000.



6 •  Getting Results with RSLogix 500™

Installing the Archive Module Extended Procedures 
Component
The Archive Module Extended Procedures Component is set of procedures 
used with MSDE to properly function with the source control database. To 
install the Archive Module Extended Procedures component:
1. Insert the RSLogix 500 CD-ROM into the CD-ROM drive. The 

installation program should start automatically.  If it does not, open the 
installation disk with Windows Explorer and run SETUP.EXE.

2. Click Install Source Control.
3. Click Install Archive Module Extended Procedures Component.
4. Follow the on-screen instructions for installing the component.

Creating the Archive Module database
To create the Archive Module database:
1. Make sure the Archive Module Extended Procedures Component is 

installed on the computer on which you want to create the Archive 
Module database.

2. Make sure MSDE is installed and running on the computer on which you 
want to create the database(s).  Once you have MSDE installed and 
running, log on to the computer as a user with administration rights.

3. Place the RSLogix 500 CD-ROM into the server computer.  The 
installation program should start automatically.  If it does not, open the 
installation disk with Windows Explorer and run SETUP.EXE.

4. Click Install Source Control.
5. Click Run Archive Module Database Creation Wizard.  This starts the 

Archive Database Wizard.
6. Step 1 of the wizard sets the name of the server on which you are going to 

install the database and how you will access the database. 
a. Leave the Server field blank (this tells the wizard to create the 

database on your computer).
b. Make sure Use NT authentication is set.
c. Click Next to continue creating the database.



Installing RSLogix 500 • 7

7. Step 2 of the wizard defines the name of the database, where the database 
is located on disk, and the properties of the database.  The following 
illustration shows how to set up this window.  When you have completed 
this window, click Next.

Type the name you
want to give to the

database here
Specify a file path
to where you want

to store the
database

Leave this setting
alone.

Make sure to check
this checkbox!

Set the file growth to be
by 10 percent

Set the maximum
size of the

database to be
unrestricted
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8. Step 3 of the wizard defines the location and size of the database 
transaction logs.  The following illustration shows how to define these 
logs.  When you have completed this window, click Next.

9. In Step 4 of the wizard, you need to identify the location of the 
RSFREPROC.DLL file.  This is a file placed on your computer when you 
install the Archive Module Extended Procedures Component.  By default, 
this file is placed in the \Program Files\Rockwell Software\RSMacSvr 
folder.  Select the location of this file, then click Next.

10. Click Finish to complete the wizard.  The wizard creates the database.

Installing the Archive Module Administration Utility
To install the Archive Module Administration Utility:
1. Insert the RSLogix 500 CD-ROM into the CD-ROM drive. The 

installation program should start automatically.  If it does not, open the 
installation disk with Windows Explorer and run SETUP.EXE.

2. Click Install Source Control.
3. Click Install Archive Module Administration Utility.
4. Follow the on-screen instructions for installing the utility.

Specify a file path
to where you want

to store the
database

transaction logs

Leave this setting
alone.

Make sure to check
this checkbox!

Set the file growth
to be by 10 percent

Set the maximum
size of the log file
to be unrestricted
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Installing the Archive Module client component
The Archive Module client component provides access to the source control 
database.  You must install and configure the Archive Module client 
component before using the source control feature of RSLogix 500.
For information about configuring the client component, see Configuring the 
source control database on page 63.
To install the Archive Module client component:
1. Log onto the computer that will run the Archive Module client 

component using an Administrator account (or an account that has 
Administrator privileges).

2. Place the RSLogix 500 CD-ROM into the server computer.  The 
installation program should start automatically.  If it does not, open the 
installation disk with Windows Explorer and run SETUP.EXE.

3. Click Install Source Control.
4. Click Install Archive Module Client Component.
5. Follow the on-screen instructions for installing the component.

Starting RSLogix 500 software 
To start RSLogix 500 software, click Start > Programs > Rockwell Software 
> RSLogix 500 > RSLogix 500.

Troubleshooting installation
If RSLogix 500 does not start up or run properly, keep the following in mind: 

Do you have the correct version of RSLinx installed?  The software requires 
RSLinx version 2.31.00 or later. 
Does your computer have enough memory? Check the hardware 
requirements on the first page of this chapter for memory requirements. 
Is the RSLogix 500 software activated?  If upon attempting to run RSLogix 
500 you see a message indicating that activation for RSLogix 500 is missing, 
you will need to move activation to your local hard drive. Put the RSLogix 
500 Master Disk in the floppy drive. Click Start, then Run. In the open field 
type x:\evmove, where x is the letter of the drive containing the Master 
disk.  See Activation on page 81 or the online help in the EVMove utility for 
more information about using software activation.
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Welcome to RSLogix 500
RSLogix 500 software is a 32-bit Windows ladder logic programming package 
for the SLC 500 and MicroLogix® processors.  RSLogix 500 is compatible with 
SLC 500 and MicroLogix programs created with any of Rockwell Software’s 
programming packages.   
RSLogix 500 software includes:

a free-form ladder editor that lets you concentrate on the application logic 
instead of syntax as you write your program
a powerful project verifier that you use to build a list of errors you can 
navigate to make corrections at your convenience
drag-and-drop editing to quickly move data table elements from one data file 
to another, rungs from one subroutine or project to another, or instructions 
from rung to rung within a project
an address wizard that makes entering addresses easier and reduces keying 
errors.
search and replace to quickly change occurrences of a particular address or 
symbol
a point-and-click interface called a project tree that lets you access all the 
folders and files contained in your project 
a custom data monitor to view separate data elements together and observe 
interactions
trending and histogram functionality for monitoring and displaying process 
data
SLC libraries for storing and retrieving portions of ladder logic for use across 
any of Rockwell Software's SLC programming software products.
a compare utility that lets you graphically view project differences.

Chapter Getting started with 
RSLogix 500
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Exploring RSLogix 500
To navigate through the various windows and toolbars in RSLogix 500 more 
easily, you should understand what they contain and what functionality each 
provides.
When you open a project in RSLogix 500 you can expect to see:.

Menu bar - Select functionality from the menus that appear as you click each 
selection on this bar.
Icon bar - The icon bar contains many functions that you will use repeatedly 
as you develop and test your logic program.  If you want to know what any 
of the icons represent, RSLogix 500 can tell you.  Move your cursor over the 
icon, and floating ToolTip window appears to tell you what the icon is used 
for.
Online bar - See at a glance the processor mode and whether you have online 
edits or forces present.  You can also view the communications driver and 
node number.

Menu bar
Icon bar

Online bar

Project tree

Results pane

Status bar
Ladder view                 Instruction toolbar
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Project tree - This view contains all the folders and files contained in your 
project.  You can usually click an icon in this tree and then click the right 
mouse button for a menu that applies only to the icon selected.  For example, 
if you click the right mouse button on a program file, you see options to 
rename the program file, open the program file, hide the program file, or 
reveal properties of the program file.
Status bar - Look here for ongoing status information and prompts as you 
use the software.
Results pane - Displays the results of a Find All search or a verification 
procedure.  You can hide this pane or place it anywhere on your screen.
Ladder view - This is where you edit your ladder logic.  You can view several 
program files at the same time.
Instruction toolbar - Displays instruction mnemonics in tabbed categories.
When you click on a category tab the instruction toolbar just above it 
changes to show that category of instructions.  Click an instruction to insert 
it in your ladder program.

Quick Start Steps
The following steps explain how to get running quickly with RSLogix 500. 

Tip You may find it more convenient to use a floating instruction palette 
from which you can select any instruction available to your 
processor.  Press [Alt+4] to view the palette.  You can resize the 
palette by dragging its lower edge.
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Step 1 • Configure a driver in RSLinx
A “light” version of

RSLinx, called “RSLinx
Lite” comes with

RSLogix 500.  This
version of RSLinx

provides the
communication drivers

necessary to use
RSLogix 500.  RSLinx
Lite will not, however,

provide
communications

through DDE or OPC –
those communication
modes are used with

other software
packages, such as HMI

or data acquisition
packages.  To use

DDE or OPC
communication, you

will need to purchase
RSLinx.

Of course, you will want your program to run in an SLC 500 or MicroLogix 
controller.  That means you will need some way to connect your computer to 
your controller – and you will have to tell the software how you are connected.  
Communications from RSLogix 500 take place through another software 
package, called RSLinx.  RSLogix 500 talks to RSLinx, which in turn talks to 
your communications devices.
A driver is a small piece of software that allows a computer to talk to other 
systems.  In this case, RSLinx uses drivers to connect your computer to your 
processor.  You have to tell RSLinx what driver you want to use to make that 
connection.
The driver you use depends on the way your processor is physically connected 
to your computer.  There is a wide variety of possibile physical connections; it’s 
important you know which type of connection your system is using and how 
that physical connection is configured.  For instance, if your processor is 
connected to your network through another computer running RSLinx 
Gateway, you need to use an RSLinx Gateway driver.  If you are directly 
connected to your processor through a 1784-KTX card, you need to use the 
driver for that card.
You will also need to know the parameters of the physical connections – for 
instance, if you are connecting through a 1784-KTX card, you will need to 
know how your KTX card is configured, the station numbers of the processors 
on your DH-485 network, and how fast your processors are communicating on 
the network.
To configure a driver in RSLinx:

d. Open RSLinx by clicking Start > Programs > Rockwell Software > 
RSLinx > RSLinx. RSLinx starts in a minimized mode – you will see 
an RSLinx icon in your Windows System Tray.  (The System Tray is a 
part of the Windows Taskbar – by default, the System Tray is in the 
lower right-hand corner of your screen.)  Click the RSLinx icon to 
open the RSLinx window.

e. In RSLinx, click Communications > Configure Drivers.  This 
opens the Configure Drivers window.

This is the RSLinx icon
that appears in the

System Tray
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f. In the Configure Drivers window, select the driver you need to use 
based on your physical connection to the processor.  For example, if 
you are connecting with a 1784-KTX card, select the 1784-KT/
KTX(D)/PKTX(D)/PCMK for DH+/DH-485 devices driver.

g. Click Add New to add the driver to the Configured Drivers list.
h. RSLinx asks you to name the driver.  RSLinx uses this name to refer 

to the driver.  You can use the default name, or enter a name (names 
can be up to 15 characters long).  Click OK.

i. The window that appears next depends on the driver you selected.  
This window is where you configure the driver.  Configure the driver 
to match your physical connection to the processor.  If you need help 
with the parameters for the driver, click the Help button on the 
window.

j. When you have finished configuring the driver, the driver appears in 
the Configured Drivers list of the Configure Drivers window.  Click 
Close.

Click the down arrow to select a 
driver from the Available Driver 
Types list

Click Add New to add 
the driver
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k. You need to make sure the communications driver you configured is 
working properly.  To do this, use the RSWho function in RSLinx.  
This function shows what processors and other communications 
devices are available through the driver.  To display an RSWho 
window, click Communications > RSWho.

l. In the RSWho tree, open the driver you configured.  You should see 
the processor to which you want to connect.  If you can see the 
processor, the driver is configured correctly and you can proceed to 
the next step.  
If you cannot see the processor, the driver is not configured correctly 
(or some other communication problem is preventing you from 
accessing the processor).  Correct the problem before proceeding.  See 
the online help in RSLinx for information about the driver you are 
using.

Step 2 • Configure system communications
There are two kinds of communications configuration in RSLogix 500.

System communications, which are set globally.  When you set system 
communications parameters, those parameters are the default for all new 
projects in RSLogix 500.
Controller communications, which are communications parameters 
specific to a given project.  When you set controller communications for a 
project, those settings overwrite the system communications settings for that 
project.  (Other new projects still use the system communications settings.)

Setting system communications parameters can save you time later.  We suggest 
you set the system communications parameters before creating your first 
project in RSLogix 500.
To set the system communications parameters:

In the RSWho
tree, open the

driver you
configured (a

Remote Devices
via Linx Gateway

driver is shown
here)
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a. From the Comms menu, click System Comms. This displays the 
Communications window.  (If RSLinx is not running, it will start.)  
The Communications window is very much like the RSWho window 
you encountered while configuring your communications driver.  

b. In the Communications window tree, open the driver you configured.  
The processor you want to program should be visible.  Click the 
processor, then click OK.

There is a great deal more that you can do from the Communications window.  
See the online help for more information.

Step 3 • Create a new project or open an existing 
project

Create a new project
Projects are the complete set of files associated with your program logic.  To 
create a new project, click File > New.  RSLogix 500 prompts you for the type 
of processor you will communicate with and creates a project tree for the 
project.  The project tree gives you access to program, data table, and database 
files.

Tip If you want to change the system communications settings, click 
Comms > System Comms.
If you want to set different communications parameters for a given 
project but leave the system communications settings alone, open 
the properties for the project’s controller.  See the online help for 
RSLogix 500 for more information.

Open the driver you
configured

Click the processor you
want to program, then

click OK
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Open an existing project
To open an existing project, click File > Open.  The software displays a 
window that allows you to choose a project to open.

Using the project tree
When you have opened or created a project, RSLogix 500 display’s the project’s 
project tree.  The project tree allows you to navigate through the various 
program and data table files in your project.
The following illustration shows the parts of the project tree.

Tip You can hide any program file (except system files) in the project 
tree.  This can be useful once you’ve completed editing a program 
file and don’t want to risk accidentally selecting it and making 
changes.  Click on the file in the project tree and then select Hide
from its context (right-mouse) menu. 

Tip Compare project files easily by clicking Tools > Compare.  Then 
select the projects you want compared.  You can print the resulting 
graphical display or save it to a report and print it later.

This symbol (-) means
that the folder’s con-

tents are already visible.
Click the symbol to col-

lapse the folder and
hide its contents.

This symbol (+) means
that the folder contains

files that are not yet
visible in the project

tree.  Click the symbol
to expand the folder and

reveal its contents.

You can rename files.
If you do, the name you 
give it will be shown 
instead of the default.
Program files 0 and 1 
are internal files and 
cannot be renamed.
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Opening Multiple Files
To open multiple files within the same project you can split the viewing 
window.

Use your mouse to point to the split bar.  The cursor turns into a double bar 
with two arrows.  Drag the bar up or down to its new position allowing you to 
see two views of the window.
You cannot view program files from different projects with only a single 
RSLogix 500 application running on your computer.  You must open more 
than one application to work on multiple projects at the same time.  Once you 
have the projects opened, you can drag-and-drop instructions and data between 
them.

Step 4 • Create program and data table files
The project tree is your entry point for creating new files or accessing existing 
files.  To create a new file, right-click the program or data file icon and then 
select New from the menu.  You will be prompted for information about the 
file.

Program files contain controller information, the main ladder program, and any 
subroutine programs.  The number of program files you can have in your 
ladder project is determined by the type of controller you are using.
Data table files contain the status information associated with external I/O and 
all other instructions you use in your main and subroutine ladder program files.  
In addition, these files store information concerning controller operation.  You 
can also use the files to store recipes and look-up tables if needed.

Split bar

Position your cursor over the
folder then click the right

mouse button and choose
New to create a new file.
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Step 5 • Define chassis and modules
After you have opened a project, you need to define your chassis, identify the 
I/O cards and their positions in the chassis, and select a power supply for each 
chassis in your configuration. 
You perform these procedures in the I/O Configuration window.  Access this 
window by double-clicking the I/O Configuration icon in the project tree.
Then click a module in the list on the right side of the window and drag it into 
the slot where you want it to reside.
From the I/O Configuration window, click the Power Supply button to 
examine the loading on a rack based on the module configuration that you have 
selected.

For more information about other tasks you can accomplish from the I/O 
Configuration window refer to Chassis and module setup on page 27.

Step 6 • Enter a logic program
When you open a program file by double-clicking its icon in the project tree, 
the ladder file opens in the right side of the RSLogix 500 window.  Usually, 
program file #2, the main program file, will open when you open a project.  If 
you have not entered any ladder logic in a program file, only the end rung will 
show.
Click the end rung and then select the New Rung icon from the user toolbar.  
To place an instruction on a rung, click the instruction’s button.

.
First, click a module in this list

Next, while still holding the mouse button,
drag the module to this side.
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You can place several instructions on a rung in sequence by clicking the icons 
one after another.  RSLogix 500 places instructions from left to right.
RSLogix 500 supports a file-based editor.  This means that you can:

create and/or edit multiple rungs at a time
enter addresses before you actually create data table files for your I/O
enter symbols before you have assigned addresses for them in the database
enter instructions without having to provide addresses until just before 
validating the file

To add addresses, click an instruction then type the address in the empty field 
that appears above the instruction.  With RSLogix 500 you can also drag and 
drop addresses from a data table file onto instructions in your ladder logic.

Remember to use the right mouse button to access functions whenever 
possible.  The right mouse button provides you with context menus that list 
editing options.  And always remember that you can click F1 (or the Help
button when available) on any instruction or within any window to access help.
Keyboard users can press the [Shift + F10] key combination to access a right 
mouse menu.

Tip As you begin to enter an address (type file letter), a wizard pops up 
a list of valid options. You can then make a selection by pressing 
[Enter] to select the default item, or navigate the list to make a 
different selection. You can also ignore the list and continue entering 
your own address.
If you want to close the wizard press the [Esc] key. It can be opened 
again by pressing [Insert] when an address/symbol entry field is 
open.

This is the “new 
rung” icon.  Click it 
to place a new rung 
on your ladder.

Each of these tabs 
displays a different 
category of instructions in 
the toolbar.  You can 
customize the categories.

If there are too many
instructions on the toolbar
to see them all, use these

arrows (right and left) to
scroll through the list.
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For more detailed information about the steps you follow to enter the ladder 
logic including information about branching, addressing, and performing 
program edits online, refer to Entering ladder logic on page 29 in this book.

Step 7 • Add documentation to your logic 
instructions

You can use several method to add symbols and descriptions to addresses in 
the database.

Modify symbols and descriptions from within a program file.  To do this, 
right-click the address in the instruction that you want to document, then 
click Edit Symbol or Edit Description.
Modify an address’s assigned documentation in the data file.  Double-click 
the data file in the project tree, and then click on an address within the grid 
that appears on the data file dialog.  At the bottom of the dialog there are 
fields where you can enter the documentation for the address.
Modify the database using the database editor.  Double-click an icon in the 
database folder located in the project tree.
Enter a symbol while creating new instructions, then assigning an address to 
the symbol using the database symbol/description editor. 
View and edit the project database using Microsoft Excel (RSLogix 500 
Professional version only)

For information about the database import and export options available to you 
refer to Importing or exporting the documentation database on page 41 in this book.

Tip You can select multiple rungs by holding down the [Ctrl] key and 
clicking the left mouse button on every rung you want to select.  You 
can also select a range of rungs by holding down the [Shift] key and 
clicking the beginning rung and ending rung.
When you select rungs in this manner, RSLogix 500 remembers the 
order in which you made your selections, and pastes the rungs to the 
clipboard in that order.  When you paste the rungs, the order in 
which you copied them is retained.  For example if you click rung 11 
and then [Shift] click rung 8 to copy a range of rungs, the rungs are 
copied to the clipboard from rung 11 to rung 8.  Pasting these rungs 
will place them in the new location in this same order.
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Step 8 • Validate your project
Before you can compile and download your project to a processor, you must 
validate the project.  Validation makes sure your project meets the basic rules 
of SLC 500 or MicroLogix programming.  You can validate a single program 
file or you can validate your entire project at one time.  To verify a file, click the 
Verify File icon or click Edit > Verify File.  To verify your whole project, click 
the Verify Project icon or clcik Edit > Verify Project.
After you initiate a verification, the Verify Results output window displays and 
gives you information about mistakes or omissions that may have occurred as 
you wrote your program logic.

The results of any verification are
displayed at the bottom of the window 
under the project tree.  To hide this 
results window after viewing it, click the 
X in the upper left corner of the window.

Click on any result item to navigate to 
the location of the error within the logic 
program.



24 •  Getting Results with RSLogix 500™

Step 9 • Configure communication channel, 
download and go online

Before going online you have to define processor communication settings, 
such as baud rate, and also decide certain system and protocol controls.
Depending on the type of processor that you are using and the method of 
communication (direct vs. networked or modem), the complexity of this 
procedure varies.
Double-click the channel configuration icon in the project tree to make these 
settings.  If you need information about any parameter, click Help on the 
channel configuration window.
Finally, click Download > Comms to download the current offline program 
into the controller.  RSLogix 500 will ask if you want to go online.  Click Yes
to go online.

Step 10 • Monitor data files
You can use RSLogix 500 to monitor what is happening in your data table files.
While monitoring these files you can:

define how your data file selection grid will display
change values in the data table
change the display radix
show which addresses are used in your ladder logic
switch between files
quickly jump to another address in another data table file
cross reference data

To monitor a data table file, click the data file icon that represents the file you 
want to monitor.  You can have multiple data table files opened for monitoring 
at the same time.  Drag each data table window into viewing position by 
clicking on the title bar and moving the mouse.  Release the mouse button to 
place the data table window.

Tip If you are developing the program offline – for example, if you are 
using a computer that is not located where you will use the program 
– you may want to override system communication settings made in 
step 1of this quick-start guide. You can override the system 
communication settings this from the Controller Properties 
window, Controller Communications tab.  Settings made through 
this method will override any driver and node settings established in 
step 1, and should be completed before proceeding with step 8.
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You can also choose to cascade or tile all the windows opened in your RSLogix 
project by selecting the Window menu item and clicking Arrange.
Data changes made offline only affect the disk file unless the program is 
restored to the processor.
Data changes made online only affect the processor file unless the program is 
saved or uploaded while online to update the disk file.
For other tips about how you can create and monitor lists of related addresses 
instead of accessing the data table files, refer to Monitoring data on page 47 in 
this book.

Step 11 • Search and replace instructions
RSLogix 500’s Find function allows you to quickly locate instructions, 
addresses, and symbols in ladder program files.  You can even search for edit 
zones within your logic program.  If you want to automatically replace 
instructions and addresses with different ones, you can use the Replace option.  
Wildcards may be used in your search.
Begin any Find or Replace operation from the Search menu.  Then type the 
mnemonic (XIC, TON, etc.), the address (B3/4, etc.) or a combination of both 
mnemonic and address (XIC B3/4) or mnemonic and symbol (XIC SYMBOL) 
for the instruction you want to locate in the Find What text box. 

Tip You can quickly navigate to a program file, rung, address, symbol or 
data table file.  Press [Ctrl+G] to display a Goto dialog.

An alternative method for searching is to click in-
side this box and type the numeric or symbolic ad-
dress or the instruction mnemonic you want 
searched.

To learn the function of any icon, point to the icon without clicking.
A ToolTip like the one shown here will appear and describe define
the function of the icon.
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Step 12 • Print a report
You can obtain a printout of various elements of your project, such as program 
files, data table files, and processor information.  Select your report choices 
from the File menu by selecting Report Options.

Tip To preview the way a ladder file will print, click Preview.  You can 
scale up the image to make the instructions appear larger on the 
printed page or scale down the image so that in cases where many 
instructions are on a rung of logic, all the instructions can fit on the 
printed page.
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After you have opened a project, you need to define your chassis, identify the 
I/O cards and their positions in the chassis, and select a power supply for each 
chassis in your configuration.
You can also display the I/O configuration for your project at any time by 
double-clicking the I/O Configuration icon in the project tree. 

The I/O Configuration dialog lets you do other tasks also.
You can learn if the power supply you have planned to use will supply 
enough power for the modules you have placed in the rack.
You can configure your analog and other specialty modules.
You can automatically read the existing I/O configuration of a processor 
node on the network.

Chapter Chassis and module 
setup

Click this button to 
call a dialog (shown) 
allowing you to select 
a processor from 
which you want to 
read the 
configuration.
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Power supply loading

Access the Power Supply Loading dialog by clicking Power Supply on the I/O 
Configuration dialog.  The Power Supply Loading dialog is informational only.  
You cannot establish any settings on this dialog.  Use it to examine the loading 
on a rack based on the module configuration that you have selected.

Analog and specialty module configuration
If you have a Specialty I/O Module in your configuration, you have to enter 
additional parameters so that the module can function properly in your 
program.  You enter this information in the Advanced I/O Configuration 
window.  Go to this dialog by clicking the Adv Config button on the I/O 
Configuration dialog.
Remember you can always click the Help button or press [F1] on a dialog if 
you are unfamiliar with any of the parameters.

Automatic I/O configuration
If you are programming an SLC 5/03™, SLC 5/04™ or SLC 5/05™ 
processor offline and have communications configured for the processor, you 
can have the processor read the actual I/O configuration for the processor and 
reflect that information on the I/O Configuration window.  This can save 
considerable time.  To do this, click the Read I/O Config button on the I/O 
Configuration dialog.

These figures
represent the current 
power supply loading 
based on your 
module configuration.

These figures 
estimate the power 
available before an 
overload occurs.

This is where you receive advisory 
messages about your power supply 
selection.
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This chapter provides information that you can use to make editing your ladder 
logic easier. 

Backing up your work
Remember to back up your work as you develop your ladder logic programs.
RSLogix 500 uses two types of backup files that you can access at any time, and 
provides you with an auto-recovery file in the case of a power failure.  All of 
these files contain the entire description database associated with the project.

Auto-Backup files are created automatically each time you save a project.
You can preset how many backups should be retained for any project by 
entering a Number of Backups on the System Preferences tab of the System 
Options dialog.  Reach this tab from the Tools menu.  Then click Options 
and select the System Preference tab.  Auto-backup files (saved as .RSS files) 
have the letters BAK and a series of numbers (000 to 999) appended to the 
filename.  For example, an auto-backup created for project TEST.RSS might 
be identified as TEST_BAK000.RSS, and a more recent backup might be 
identified as TEST_BAK001.RSS.
Compressed Format Backup files are typically generated for archiving or 
giving to another user.  Compressed format backup files include the .RSS 
and all database files for the project compressed into a single .RS1 file.  From 
the File menu click Backup Project to generate a compressed-format backup 
file.

Chapter Entering ladder logic

Tip Shortcut methods exist for most editing functions within RSLogix 
500.  You can access this list of shortcuts in the online help by 
searching the word “shortcuts” in the online help.
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Crash Recovery
If you experience a power interruption, RSLogix 500 provides you with a recent 
backup file containing current edits.
RSLogix 500 automatically creates file backups while you are working with a 
project and when you save the project.  This auto-generated recovery file 
(internal RSS file) is only available to you the next time you open a project if 
you have a system crash or your power  is interrupted.  After attempting to 
open a project after a power failure RSLogix 500 prompts you with choices.
You can open:

the auto-saved file, ensuring retention of any edits made before the power 
interruption.
the last backup that you made, when you selected Save before the power 
interruption.

You can set the interval time at which auto-recovery saves of your project will 
occur.  Do this by making a setting in the Preferences dialog.  The auto-
recovery process ensures that you will be able to retain any work that had been 
done on the file between the time of the power interruption and the last manual 
save.

Tip You must have saved or closed the file you are working on at least 
one time for the auto-recovery process to work.  Therefore, it is 
good practice to save the file immediately after beginning a new 
project.  This ensures that your auto-recovery process can begin 
properly.
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Quick entry of instructions
To make your programming tasks faster, RSLogix 500 lets you map any 
available alphabetic key (A-Z) on your computer keyboard to a ladder logic 
programming instruction.

From the View menu click Properties.  Then click Quick Key Mapping to 
access the mapping list.  Make sure you have a program file window opened 
and active or you will not be able to select Properties from the View menu.

Tip You can jump to any rung in your project by clicking the Search 
menu, and then clicking Goto.  You can go to a rung in the current 
program file or you can go to a rung in another program file within 
the same project.Keyboard users can press the [Ctrl + G] key 
combination to access the Goto Rung dialog.

Double-click the word 
Free anywhere in this 
list.

Then click a 
mnemonic from the 
drop down list to 
assign it to the key-
board key and make it 
a quick key.
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Floating instruction palette
As a convenience for selecting instructions RSLogix 500 lets you display a 
floating instruction palette.  From the View menu click Instruction Palette or 
click the palette icon.

You may have to resize the palette for your screen.  To do this click on the 
lower edge of the palette window and drag to an appropriate size.

Addressing
There are several different methods that you can use to address instructions.
You can enter an address by:

manually typing it in
dragging addresses from data files or the CDM (Custom Data Monitor)
using copy and paste from program to program

icon

palette

Tip You can drag-and-drop rungs, branches, instructions, and addresses 
from file to file or from the database to a file.  To drag-and-drop, 
position the mouse pointer over a file element, click and hold down 
the left mouse button and drag the element to another location, and 
then release the mouse button.  Red boxes indicate valid locations; 
these turn green when properly selected. 
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Branching

Add a branch

Move a branch

Expand a branch

Nested branches

Parallel branches

Click this icon on the instruction toolbar to place a branch 
in your ladder logic.  If your cursor is on an instruction, the 
branch is placed immediately to the right of the instruction.  
If your cursor is on the rung number, the branch is placed 
first on the rung.

Click on the upper left corner of a branch to move the 
entire branch structure to another location in your ladder 
logic program.

Click the right leg of the branch, then drag the leg to the 
right or left.  Valid release points will be visible on the 
ladder display.

Place the cursor at the upper left corner of a branch leg, 
click the right mouse button, and select Append New 
Branch to place another branch structure within the 
original branch structure.

Place the cursor at the bottom left corner of a branch leg 
and click the right mouse button to Extend Branch Leg Up 
or Extend Branch Leg Down.
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Copy branch leg

Copy entire branch structure

Delete a branch
Place the cursor at any location on the branch and click the right mouse button.  
Then click Delete.  If you cut or delete a branch, all instructions on the branch 
are also deleted.

Branching restrictions
You are limited to a maximum of 75 parallel branches.
You are limited to a maximum of 4 nested branches. (SLC 5/02 and higher and 
MicroLogix).

Undo operation
The undo icon reverses your last action.  You can use this icon to walk through 
(and undo) your previous actions one at a time.  RSLogix 500 remembers up to 
200 previous actions.
If you want to undo a move operation, you must click undo two times.  This is 
because RSLogix 500 considers a move a series of two actions (copy and cut).  
You have to let RSLogix know that you want both the copy and the cut undone.  
If you click undo only one time when trying to undo a move, the move appears 
to be a copy, and you will see the moved element appear at both locations.

Click on the left edge of the branch leg you want to copy.  
In the picture at the left this is the center leg.  Then click 
copy in the right mouse menu.  Finally click on a rung or 
instruction in your logic and click paste from the right 
mouse menu to insert the rung leg 

Select the right leg of the branch structure, then click copy 
in the right mouse menu.  Finally click on a rung or 
instruction in your logic and click paste from the right 
mouse menu to insert the rung structure.
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Online editing
The online editing function lets you monitor and correct your ladder program 
when your programming terminal is connected to a SLC 5/03, SLC 5/04 or 
SLC 5/05 processor.  Only one programming device at a time can perform 
online edits of the program.
Online editing functions consist of inserting, replacing, and deleting rungs in an 
existing ladder program while online with the processor. 
Within your logic program RSLogix 500 places zone markers in the margin to 
the left of the left rail.  These letters signify edit zones and they indicate the type 
of ladder program edit that exists in the program.
Lower case zone markers indicate edits that exist only in the computer memory.  
Upper case zone markers indicate edits that exist in the processor memory.
After successfully assembling the edited rungs, the zone markers disappear. 

Tip You can search for zone markers in your project the same way you 
might search for an instruction or an address.  To do this, click the 
Special button on the Find dialog.
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Lower case zone markers

Upper case zone markers

e (Offline and online, all controllers)  These rungs are currently under edit within 
the computer RAM.  If you are working offline, after a successful program 
verification the lower-case e will disappear and the edits will be incorporated 
into the program. If you are working online, after accepting the rung, the 
lower-case e will be replaced by an upper-case I indicating that the rung is now 
in the controller's memory and will be inserted into the program file. 

i (Online Editing, SLC 5/03, 5/04 and 5/05 controllers only)  These rungs are 
to be inserted into the program.  Rungs marked with a lower-case i currently 
exist in the computer memory and will not be entered into the controller until 
the rung is accepted (right mouse button selection).  After the rung is accepted, 
the lower-case i is replaced by an upper-case I.

r (Online Editing, SLC 5/03, 5/04 and 5/05 controllers only)  These rungs are 
to be replaced in the ladder program.  Rungs marked with a lower-case r 
currently exist in the computer memory and will not be entered into the 
controller until the rung is accepted (right mouse button selection).  An r 
marked rung is always preceded by an e marked rung.   After the rung is 
accepted, the lower-case r will be replaced by an upper-case R.

d (Online Editing, SLC 5/03, 5/04 and 5/05 controllers only)  These rungs are 
to be deleted from the ladder program.  Rungs marked with a lower-case d 
indicate a deletion reflected in the computer memory.  This deletion will not 
be reflected in the controller until the rung is accepted (right mouse button 
selection), at which time it will be replaced by an upper-case D.

I (Online Editing, SLC 5/03, 5/04 and 5/05 controllers only)  These rungs have 
been inserted in the controller's logic program.  You can test the edits by 
selecting the Edit menu and clicking Test Edits to see how the rung works in 
the online ladder program.  Click Assemble Edits to finalize the rung insertion 
and complete the editing process.

R (Online Editing, SLC 5/03, 5/04 and 5/05 controllers only)  These rungs have 
been replaced in the controller's logic program.  Rungs marked with an upper-
case R continue to function in the program until you select Test Edits to see 
how the new rung works in the online program.  Select Assemble Edits to 
finalize the replacement and complete the editing process. 

D (Online Editing, SLC 5/03, 5/04 and 5/05 controllers only)  These rungs have 
been deleted in the controller's logic program.  Rungs marked with an upper-
case D continue to function in the program until you select Test Edits to see 
how the program functions without the rungs in the online program.  Select 
Assemble Edits to finalize the deletion and complete the editing process.
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Online editing example
This example replaces an XIC instruction with an XIO instruction with the 
same address while online. 
1. Select the rung in the program that requires editing and then from the 

Edit menu, select Start Rung Edits from the main menu or choose Start 
Rung Edits from the right mouse menu. A duplicate of the selected rung 
(preceded by the e edit zone marker) is shown in your program.  This is 
the rung that all edits will be performed on.  The r edit zone marker 
precedes the original rung (rung to be replaced).  See the example below. 

2. Make the edits to the rung.  The lower-case edit markers do not change 
since they represent changes that only exist in the computer memory; 
these changes are not yet a part of the online program in the controller.  
(At this step you can click Cancel Rung Edits to cancel the edits you have 
made to the rung.)

3. Select Accept Rung.  This changes the edit zone markers and places both 
rungs in the controller memory.  The upper-case I represents the rung 
that has been inserted into the online program.  The upper-case R 
represents the online rung that is to be replaced.  At this time the R rung 
is still operating in the program.

4. Select Test Edits.  The I-marked rung takes precedence.  The program in 
the controller will operate with the inserted rung, and the R-marked rung 
will be ignored. (Alternately you can click Cancel Edits to cancel the 
accepted I-marked rung and retain the originally programmed R-marked 
rung instead.)
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5. Select Assemble Edits.  All edit zone markers disappear and the edits are 
incorporated into the online program.  There is no Undo option after 
online edits have been assembled.
Going from online to offline with rungs under edit removes the RAM 
online edits.  Make sure you have accepted edits before going offline if you 
want any changes retained in the processor.

Online editing restrictions
Your programming terminal must be connected to a SLC 5/03, SLC 5/04 or 
SLC 5/05 processor.  During an online editing session you cannot:

resize data table files
create or delete program files 
change program file protection
change index across file boundaries flag
reconfigure the I/O
select force protection

ASCII editing
ASCII Editing is a function of RSLogix 500 that lets you modify instructions 
using ASCII instruction mnemonics instead of having to modify instructions 
using the ladder editor.
A quick way to call the ASCII Editor is to double-click a rung number in the 
left margin.  If you double-click a rung with logic already on it, you will see the 
mnemonics for the existing instructions and can modify or add to them.  If you 
double-click an empty rung, you get an empty editing box into which you can 
type the mnemonics that represent the logic you want placed on the rung.

Configuring interrupts
Use interrupts to interrupt the scan of the main program to accomplish a 
certain task.  Programming requires you to enter essential criteria  for the 
interrupt to function properly.  Depending on the processor you are using, this 
criteria is entered into the Status file by accessing it directly (All SLC processors 
and MicroLogix 1000 processors) or by entering the appropriate data in the 
Function File utility (MicroLogix 1200 and 1500 processors only). 

Tip Another quick method to call the ASCII text editor is to click the 
rung number and then press the forward slash key (/) on your 
keyboard.
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Selectable Timed Interrupt
Use the selectable timed interrupt (STI) function to interrupt the scan of the 
main program file automatically, on a periodic basis, in order to scan a specified 
subroutine file.  You can specify the time interval when your selectable timed 
interrupt routine will execute.

Discrete Input Interrupt
Use the Discrete Input Interrupt (DII) for high-speed processing applications 
or any application that needs to respond to an event quickly.  This function 
allows the processor to execute a ladder subroutine when the input bit pattern 
of a discrete I/O card matches a compare value that you programmed.

Processor Type: Action:

All SLC  and ML 
1000

Select a program file for the STI by double-clicking the S2 
data file icon in the project tree.  Then click the STI tab and 
enter the information needed to define the STI.  Press the 
Help button if you need more information.

ML1200 and 
ML1500

Select a program file for the STI by double-clicking the 
Function Files icon in the project tree.  Then click the STI 
tab and enter the information needed to define the STI.
Press the Help button if you need more information.

Processor Type: Action:

All SLC   Double-click the S2 data file icon in the project tree.  Then 
click the DII tab and enter the information needed to define 
the DII.  Press the Help button if you need more information.

ML1000  ML1200 
ML1500

Unavailable with these processors.
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Introduction
The import and export utilities are available from the Tools menu by clicking 
Database.  Use the import functionality in RSLogix 500 when you want to apply 
documentation that already exists to a project you are currently developing in 
RSLogix 500.  Use the export functionality in RSLogix 500 to make the 
database documentation that is part of your current RSLogix 500 project 
available to other projects.

Import database
You can apply documentation to newly created logic files by importing existing 
database documentation.  The existing documentation might come from:

projects developed using Rockwell Software's DOS-based AI or APS 
programming software
another project developed using RSLogix 500
a spreadsheet application, like Microsoft Excel™ (saved as a .CSV file)
an ASCII text file

Sometimes when you import a documentation database, there may be 
conflicting entries in the import file and the database.  This is called a collision.  
Before you begin any import you can select if you want the imported database 
instance or the current database instance discarded if collisions occur. 

Chapter Importing or exporting 
the documentation 
database

Tip RSView products can read the documentation database directly 
from your RSLogix 500 projects – there is no need to export the 
database when using RSView.
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A.I. project documentation database
Choose the Native Import option in the Database menu to import database 
documentation consisting of:

address symbols and descriptions (.DSC files)
page title and rung descriptions (.RPD files)

APS project documentation database
Choose the Native Import option in the Database menu to import database 
documentation consisting of:

address symbols and descriptions 
page title and rung descriptions 
instruction comments 

By default the file type selected for import is a .OP$ file.  The .OP$ file is the 
database control file.  It references individual database files (for example the 
symbol/description file or the page title/rung description file) that reside in the 
same folder as the .OP$ file.  After an import completes, RSLogix 500 creates 
a log file that informs you which database files successfully imported and which 
database files contained errors and could not successfully be imported.

RSLogix 500 documentation database
Choose the Native Import option in the Database menu to import database 
documentation consisting of:

address symbols and descriptions 
page title and rung descriptions 
instruction comments 
symbol groups

By default the file type selected for import is a .CTD file.  The .CTD file is the 
database control file.  It references individual database files (for example the 
symbol/description file or the page title/rung description file) that reside in the 
same folder as the .CTD file.  After an import completes, RSLogix 500 creates 
a log file that informs you which database files successfully imported and which 
database files contained errors and could not successfully be imported.  For a 
complete list of RSLogix 500 file extensions for individual database 
documentation refer to the online help and search "file extensions."

CSV (Comma Separated Values) file
Choose the ASCII Import option in the Database menu to import database 
documentation contained in a .CSV file and consisting of:
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address symbols and descriptions 
instruction comments 
symbol groups

For an example of a .CSV file, refer to the online help and search "CSV format 
for import/export."

ASCII delimited text file
You can import documentation files that were created using RSLogix 500 
software or AI software and exported and saved as ASCII delimited files.
ASCII delimited means that the fields for each RSLogix 500 database record 
are enclosed in quote marks and separated by commas.
Choose the ASCII Import option in the Database menu to import database 
documentation contained in an ASCII delimited text file.  Choose from:

address symbols and descriptions (.EAS files)
page title and rung descriptions (.ERP files)
instruction comments (.EIC files)
symbol groups (.ESG files)

Users can specify any extension instead of the default extension for each file 
type (shown above in parenthesis) when using Rockwell Software's AI or 
RSLogix 500 software.
An example of each of the above files can be found in the "ASCII Export" 
section of this manual.

Export database
Use the export functionality in RSLogix 500 to make the database 
documentation that is part of your current RSLogix 500 project available to 
other projects.
You can select the display format for descriptions in the exported file.  Choose 
"treat descriptions as five, 15-character lines of text" if you are exporting a 
database that will be used by Rockwell Software's AI or APS programming 
packages.
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You can export documentation to the following output formats:
ASCII delimited RS500 format
ASCII delimited AI format
ASCII delimited APS format
a comma separated value file (.CSV file)

After it has been exported, you can edit the ASCII file with a text editor, or load 
the file into another database.
When you export database documentation to AI or APS ASCII delimited 
format, the symbols, descriptions, and instruction comments may be truncated 
due to size restrictions imposed by the AI/APS databases.  This may result in 
conflicts in the exported data.

RS500 ASCII delimited text file examples
The examples in this section show how the documentation would be 
represented in an exported ASCII text file, using the RS500 output format.
Each field in a line of ASCII text is enclosed by quotes and separated by a 
comma.

Address symbols and descriptions (.EAS files)
"B30","0","SYMBOL","description","","","","","0","","","0","GROUP_NAME"

ASCII Field # Maximum Length Contents

1 39 characters Address

2 -- Scope (0=global, 2-255=local program file #)

3 20 characters Symbol

4 20 characters Description line 1

5 20 characters Description line 2

6 20 characters Description line 3

7 20 characters Description line 4

8 20 characters Description line 5

9 12 characters Device code (always 0 for addresses that are 
not real I/O)

10 9 characters Device description above

11 9 characters Device description below

12 -- Disable xref flag, (0=enabled, 1=disabled)

13 20 characters Symbol group name
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Page title and rung descriptions (.ERP files)
"RUNG000002-000002","page title","rung comment\"

Instruction comments (.EIC files)
"B3/0","XIC","ins comment","","","",""

Symbol groups (.ESG files)
"GROUP_NAME","description"

A.I. ASCII delimited text file examples
These examples show how a line might appear in an ASCII text file exported 
using the AI output format.  Each field in a line of ASCII text is enclosed by 
quotes and separated by a comma.

Address symbols and descriptions (.EAS files)
"B3/0","0","SYMBOL","description","","","","","0","","","0"

The field breakdown of AI ASCII delimited text is the same as shown for 
RS500 ASCII output format, except the symbol and description fields are 
limited to 15 characters and there is no symbol group field.

ASCII Field # Maximum Length Contents

1 39 characters Data table address or rung identifier

2 -- Page title

3 20 characters Rung description

ASCII Field # Maximum Length Contents

1 39 characters Address

2 3 characters Instruction type

3 20 characters Comment line 1

4 20 characters Comment line 2

5 20 characters Comment line 3

6 20 characters Comment line 4

7 20 characters Comment line 5

ASCII Field # Maximum Length Contents

1 20 characters Symbol group name

2 80 characters Symbol group description
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Page title and rung descriptions (.ERP files)
"RUNG002-0002","page title","rung comment\"

The field breakdown of AI ASCII delimited text is the same as shown for 
RS500 ASCII output format.

APS ASCII delimited text file
APS documentation database files saved to ASCII text format contain 
keywords.  Keywords tell the software whether the information immediately 
following the keyword is a rung comment, an instruction comment, an address 
comment, or a symbol.  Symbol and address comment examples are shown 
below.
SYM     B3/0     SYMBOL
AC      B3/0     “descriptio”
Refer to your APS programming manual for a complete list of keywords and 
an explanation of how an APS ASCII text file is built.

CSV format
Search "CSV format for import/export" in the RSLogix 500 online help for 
complete details.
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Introduction
RSLogix 500 provides you with several customized methods for monitoring 
data in your data table files.

Multipoint Monitor
Custom Data Monitor
Custom Graphical Monitor (RSLogix Professional version only)
Recipe Monitor
Histograms
Trending
Data Logging (MicroLogix 1500LRP only)
Cross Reference Report

The Multipoint Monitor and Custom Data Monitor methods let you compose 
lists of addresses that you monitor frequently, or lists of addresses with 
interrelated functionality, so that you can view, document, protect or even 
force the changing data values from a single source file.
The Custom Graphical Monitor interprets the Custom Data Monitor 
graphically with easily customized buttons, sliders, gauges and charts.
The Recipe Monitor is a variation of the Custom Data Monitor used specifically 
for monitoring groups of related indirect addresses with a common index. 
When you are online, you can use histograms and trends to see how your 
program is behaving over time, by examining bits as the program runs in the 
SLC controller. A trend logs the data for more than one address (typically 
related) over a period of time. A histogram logs the data contained in a single 
address over a period of time.
The data logging feature lets you use ladder logic to enable recording data for 
predefined sets of addresses. Your data can be date and time stamped.
The Cross Reference report lists every occurrence of all logical addresses in 
your project.

Chapter Monitoring data
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Multipoint Monitor
This is only available with MicroLogix 1000, SLC 5/03 - OS302, SLC 5/04 - 
OS401 and OS410, and SLC 5/05 controllers.  The Multipoint Monitor 
function can only be used to monitor bit addresses.  If you want to monitor 
word addresses as well as bit addresses, use the Custom Data Monitor.
Bit addresses in a multipoint list can come from any data table file.  They do 
not have to be from the same data table file.
You can use a multipoint list to:

change the on/off state of bits
set and clear forces on I/O points
define separate descriptions for on and off state 
write protect a bit

To access the Multipoint Monitor feature, double-click the Multipoint Monitor 
icon located in the project tree.

The offline multipoint list is stored in the project file.  It is not part of the 
processor image. The online multipoint list is stored in the processor memory 
and is, therefore, cleared whenever the processor memory is cleared.
When using the MicroLogix controller, descriptions are always stored in 
the.RSS file. With the SLC 5/04 and SLC 5/05 controllers the descriptions are 
stored in the processor.

Forces
To monitor forces, double-click the input or output force file in the project 
tree.

You can provide 
separate
descriptions (up to 
16 characters) for 
the on- and off- 
state of a bit.

Use only bit addresses in a multipoint monitor list.

Caution All force functions can result in sudden machine movement, 
possibly injuring personnel or causing equipment damage. USE 
EXTREME CAUTION WHEN USING FORCES!
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You can also use the Forces dialog to install and enable or disable forces while 
you are monitoring your file offline, or in any processor mode while monitoring 
your file online. Use the right-click menu on a bit in the Forces dialog to force 
the bit on or off. For more information about forcing, refer to the online help.

Custom Data Monitor (CDM)
This is available with all controllers.  The Custom Data Monitor function can 
be used to monitor bit addresses and word addresses.
Addresses in a custom data monitor list can come from any data table file.  They 
do not have to be from the same data table file.
Features of the custom data monitor include:

CDM lists can contain bit addresses or word addresses.
CDM lists can contain ASCII comments to help you clarify bit listings.
You can define up to 255 (CDM) lists per project (0-254, inclusive).
The CDM name is limited to 20 characters. 
The CDM description is limited to 59 characters. 
You can click and drag addresses from the data tables to the CDM file.
You can use the [Ctrl] and [Shift] accelerator keys to drag more than one 
address at a time from the data tables. 

To access the Custom Data Monitor feature, double-click the CDM file icon 
located in the project tree.

Custom Graphical Monitor
This feature is only available in the RSLogix 500 Professional version.
The Custom Graphical Monitor provides the data monitoring of a Custom 
Data Monitor, but in an easy to interpret graphical representation. The Custom 
Graphical Monitor is a form on which you can place ActiveX controls for 
buttons, sliders, gauges and charts as well as text and imported images. As is 
typical of ActiveX controls, you place and configure controls with the form in 
Design mode and switch to Run mode to activate the controls.

By default an untitled CDM file (#0) is included in your
project.  Rename this file when you add your addresses.
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To access the Custom Graphical Monitor feature, double-click the CGM folder 
located in the project tree. 

Recipe Monitor
The Recipe Monitor is a variation of the Custom Data Monitor. The Recipe 
Monitor is used specifically for monitoring groups of related indirect addresses 
with a common index.
Many SLC and MicroLogix projects contain data tables in which each element 
is relevant for a different mode of operation. When these data tables are 
grouped such that element 1 of each file corresponds to mode 1 of the 
assembly line used to make product 1, this is referred to as a “recipe.” The 
easiest way to keep track of recipes is to use a common reference address with 
indirect addresses to each of the related data files. The Recipe Monitor provides 
an easy and intuitive interface for this type of application.

To create a new Custom Graphical Monitor file, right-
click the Custom Graphical Monitors folder and 
select New.
By default an untitled Custom Graphical Monitor file 
(#0) is included in your project. Right-click and select 
Properties to rename this file.

Drag an address from the lad-
der or data table to a control.

Click one of these buttons to 
add text, buttons, sliders, 
gauges, images, or graphs 
to the form.

Click here to toggle 
between Run and 
Design mode.

Displays the 
current mode.

Right-click a control and select Properties to change 
colors, define ranges, and set other options.
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To access the Recipe Monitor feature, double-click the Recipe folder located in 
the project tree.

Trends
A Trend logs the data for more than one address (typically related) over a 
period of time. Contrast this with a histogram which logs the data contained in 
a single address over a period of time.
This option provides the features of the RSTrendX Viewer plus remote 
trending capability. The RSTrendX Viewer is an ActiveX control for displaying 
process data in a trend or strip chart recorder format. It is based on the Viewer 
display in the RSTrend Data Acquisition and Trending software. 
To create a Trend chart right-click the Trends folder in the project tree and 
select New. Trends are saved with the project. Logged data is not retained. You 
can create a trend configuration while offline or online. You must be online to 
trend data.

Histograms
Use the histogram functionality in RSLogix 500 to get information about how 
an address's data value changes over time.
You must be online with the SLC controller to access the histogram function. 
From the Comms menu, click Histogram to display the Histogram dialog.

To create a new Recipe Monitor file, right-click the 
Recipe Monitors folder and select New.
By default an untitled Recipe Monitor file (#0) is 
included in your project. Right-click and select 
Properties to rename this file.

Drag a data file from the 
project tree to the Recipe 
Monitor. Note that an 
asterisk (*) represents the 
indexed part of the
address. If you type in or 
drag an address from the 
ladder, be sure to use an 
asterisk to indicate the 
indexed part.
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By clicking Start on this dialog, the histogram function sends a message to the 
SLC controller to begin logging data.  Each time the address value changes, the 
controller stores the value for the address in a histogram buffer, logging both 
the new value and the time interval between value changes.  This data is 
represented in the top portion of the histogram display window.
If you frequently log certain data, you can save the configuration and simply 
load it without having to enter new parameters each time. Use Save and Load 
(accessible from the right mouse menu) for this functionality.

Data Logging (MicroLogix 1500LRP only)
Use the data logging feature to define and edit data sets for later retrieval by a 
communication device.  The data is retentive in the controller through power 
cycles.

Use this drop-down list box 
to select a time base for the 
histogram (in seconds).

If you don’t see data values 
changing, it is possible that 
your time base is incorrect 
for the addresses you are 
monitoring.



Monitoring data • 53

Access data logging from the project tree by clicking the Configuration icon in 
the Data Logging folder. Then right-click on Data Log Configuration and 
select New from the context menu

Enable data logging for any queue when the DLG instruction in your ladder 
logic designating that queue goes from False to True.

Cross Reference
A Cross Reference report lists all logical addresses in your project and gives the 
location of every occurrence of each address. The report includes the following 
data: address, symbol, instruction mnemonic, file # (and name), and rung #. 
You can sort the Cross Reference report by symbol or by address.
As an alternative to a Cross Reference report, you can choose to display cross 
reference information right on the ladder view. To use this feature, select View
> Properties, and click the Address Display tab. Make sure either or both 
check boxes are checked in the Cross Reference Display area of the dialog.

This is the number of samples 
that you would like for each 
record retained. When this limit is 
reached and a new sample is 
recorded the oldest record 
is dumped from the record.

By default the separator 
character is a space.
Although it may look like 
there is nothing in this box, 
there is actually a space 
character.

Type an address here and then 
click Accept or press [Enter] to 
place it in the current address list.

Tip You can disable cross references to get online faster. Select Tools > 
Options. Click the XRef/Address Wizard tab and uncheck the 
Enable Cross Reference Online box.
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Introduction
SLC library files are ASCII text files of the processor memory that contain the 
ladder logic, data table file, and force tables.  By  exporting (saving to file) and 
importing (loading into a new project) these SLC files, you can reuse existing 
work.  SLC files can be opened in any ASCII text editor and modified for use 
in your projects.
Things to remember about library files

Only verified project data can be saved to a .SLC file.
Exported SLC libraries limit symbols to 15 characters.  If you have a project 
file with database symbols that are 20 characters in length, exporting the 
project to a SLC library will truncate the symbols to 15 characters maximum.
Graphics characters are not allowed.
The file name of the ASCII file can contain up to eight characters consisting 
of (A-Z, 0-9, or the underscore character).
The file extension of the ASCII processor memory file must be SLC.
The text editor you use with an ASCII text file must produce only printable 
ASCII characters, with no control characters or hidden characters.

Exporting libraries
You can save entire projects or partial libraries.  To save a partial library, select 
the rungs you want to save in the library.  If you select no rungs a complete save 
occurs.  Then from the right mouse menu click Copy to SLC Library, and after 
supplying the path and filename, click Save.

Chapter Saving and loading SLC 
libraries

Tip You can examine any error messages resulting after an import or 
export operation by examining the .LOG file.  This file is stored in 
the folder named on the Preferences tab accessed by clicking the 
Tools menu and selecting Options.  You can change this default 
folder.
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You can place a description in the SLC file by typing the description in the 
Library Description field.  This description appears when you import the 
library.

Importing libraries
To import a library file, open the project into which you want to load the 
library.  Then from the right mouse menu click Paste from SLC Library.
If you are loading a complete program image into an existing project, data table 
values in the library will overwrite values in the base program, and incoming 
rungs will be appended to existing program files.

If you choose Partial Save, make sure 
you selected the rungs before displaying 
this window.

Checking Annotate Library places additional information 
in the SLC file about the rungs’ position in the original 
program.  This information is used for troubleshooting a 
library file, and can help you if you intend to manually edit 
the .SLC file in a text editor.
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If you are loading a partial library, select the rung in your program that you want 
the library rungs to precede.  The library rungs will always be placed before the 
rung you select.  Data table values from the library will overwrite existing data 
table values for those addresses already present in the base project

Choose the indexed mode and then click the Edit Index button if 
you want to display a Fixup table from which you can adjust the 
addresses in the imported library so that there are no conflicts with 
the addresses in the base program.

If you change base address I:000/0 to I:016/00 (in the 
Fixup column) and press [Enter], the addresses that 
are relative to I:000/00 change to follow the change in 
the base.  If there were more addresses relative to base 
address I:000/0, each one would be offset by the 
change applied to the octal base address.  Relative 
addresses include all the addresses in the list of the 
same data file up to the next Base address.

You can change the type address.  
Double-click and select Base, 
Relative, or Global from the drop-
down listbox.  An address set to 
Global is not affected by indexing 
to a preceding base address.
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RSLogix 500 comes in two editions: a Standard edition that provides basic 
ladder logic editing functions, and a Professional edition that provides 
additional functions to expand your automation solutions and make editing 
ladder logic simpler.  This chapter briefly describes the features included in 
RSLogix 500 Professional.

Microsoft® Visual Basic for Applications® support
RSLogix 500 Professional allows you to expand your automation solutions 
through Microsoft Visual Basic for Applications (VBA).  VBA allows you add 
and edit Visual Basic code within the RSLogix 500 development environment.  
RSLogix 500 Professional includes an object model that you can access through 
VBA.  VBA code created through RSLogix 500 Professional is stored in your 
projects’ .RSP files.
You can run VBA code with RSLogix 500 Standard – to create or edit VBA 
code you must use RSLogix 500 Professional.
See the manual titled RSLogix Automation Interface Reference Manual for more 
information about using VBA in your automation solutions.  This manual is 
included with RSLogix 500 Professional.

Source Control
RSLogix 500 Professional has a source control feature that you can use to help 
you maintain version control on your projects.  
For information about installing the source control feature, see Installing the 
source control feature on page 5.
For information about using source control, see Source control on page 63.

Custom Graphical Monitor
The Custom Graphical Monitor provides graphical data monitoring for your 
projects.  In the Custom Graphical Monitor, you can place graphical buttons, 
sliders, gauges, charts, text, and imported images.  

Chapter Features in RSLogix 500 
Professional
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See Custom Graphical Monitor on page 49 for more information about using this 
feature.

Editing project databases using Microsoft® Excel®

RSLogix 500 Professional allows you to view and edit project databases with 
Microsoft Excel software.  Microsoft Excel 97 (and later versions) comes with 
an ActiveX control that RSLogix 500 can use.  You must have Microsoft Excel 
installed on the same computer as RSLogix 500 Professional to use this feature.
The Microsoft Excel ActiveX control gives you the powerful editing features 
of Excel, such as search/replace, and modifying multiple records at the same 
time.  Using this control minimizes or eliminates the need for database import/
export operations.
To access the Excel editor, click Tools > Database > Edit Using Excel. The 
Address/Symbol Editor will open using Excel as the editing tool. 
Pressing [F1] will access the Microsoft Excel Help system. 
When the Excel editor is displayed and has focus, RSLogix 500 displays the 
Excel menus and toolbars. You can also access Excel functions by using the 
right-mouse button menus while working in the editor. 
Keep the following information in mind when using Excel to edit the database:

When you open the Excel editor, the entire contents of the Address/Symbol 
database is automatically loaded into the control. 
Changes made within the Excel editor will not be applied to the Address/
Symbol database until you click Apply or OK.  When you apply changes, the 
entire Address/Symbol database will be overwritten with the contents of the 
Excel editor. 
Empty rows within the Excel editor are be ignored when applying the 
contents to the database. 
If records are added, removed, or moved within the Excel editor, they will 
be sorted when the contents are applied to the Address/Symbol database. 
When you click Apply or OK, all legal records will be written to the 
Address/Symbol database. Illegal records (records containing illegal 
characters, fields with too many characters, duplicate records, etc.) will not 
be written to the database. 
Any errors or illegal records encountered when applying the contents of the 
Excel editor to the database will be logged and displayed in a separate 
window. You have the option of saving this information to a file. 
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If you close the Excel editor without clicking Apply or OK (by clicking 
Cancel), the editor closes without overwriting the database. Changes made 
in the editor since the last Update Changes operation will be lost. 
The Excel editor is limited to approximately 64,000 rows per sheet. 
Databases with more than 50,000 records will have their contents spanned 
to multiple Excel sheets. 
All standard features of the Excel Active X control will be available to 
manipulate the database. When the Excel editor has focus, these features are 
accessed through the menus or toolbars or from the right-mouse menu. 
Remember, you can always get help with the Excel editor by pressing the 
[F1] key. 

Logic Trace
The Logic Trace feature lets you navigate through your ladder logic like using 
a Web browser.  As you move your cursor through a ladder logic project, the 
Logic Trace feature keeps track of where you have been.  You can then use the 
Logic Trace toolbar to navigate back to previous positions, or from earlier 
positions to later ones.
You can turn the logic trace toolbar on or off by clicking View > Toolbars and
selecting or deselecting the Logic Trace toolbar. 

How logic trace works
As you move your cursor through the ladder logic, the software records the 
positions of your cursor. When no back or forward history is available, the logic 
trace arrow buttons are disabled (grayed out). 

Back button Forward button

Back menu Forward menu
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Actions that create a “back” navigation history include cross reference 
navigation, program file display change, clicking your mouse on ladder logic 
rung/instruction elements, searching ladder logic, using the Goto Rung 
function, using dot commands, etc. Using the keyboard arrow keys will not 
generate a navigation history. 
Actions that create a “forward” navigation history are limited to clicking an 
enabled “back” toolbar button or selecting a location from the “back” pull 
down menu. 
When you click a “back” button, the cursor will move to the previous location 
in the navigation history. Once you have moved backward in the navigation 
history, clicking the “forward” button will move the cursor forward through 
your navigation history. 
The pull down menus are limited to a maximum of 10 entries. Each entry lists 
a rung/instruction location. While the menus are limited to showing a 
maximum of 10 entries, the arrows allow you to go much farther back.
If you delete an instruction or rung that is in the history, that item is removed 
from the logic trace navigation history. If you edit a rung or instruction that is 
in the navigation history, it remains in the history. 
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About source control

Keeping track of changes to your projects can be a challenge.  The source 
control system of RSLogix 500 Professional can help you manage changes to 
your projects.
The source control system acts as a project library, allowing you to “check out” 
and “check in” your project files.  Project files are stored in a database.  When 
you want to work on a project that is stored in the database, you check out the 
project.  When you are finished working on it, you check it back into the 
database.  When you check a project in or out of the Archive database, the 
database records that you have done so.  You can also record comments when 
you check out or check in a project.
If you want a copy of the latest version of a project without checking it out (or 
if it has been checked out by someone else), you can “get” the project file.
When you get a project, the system places a read-only version of the project 
onto your computer. 

Configuring the source control database
You must configure the source control database to allow users to access it.  Use 
the Archive Administration Utility to set permissions for the database.

Chapter Source control

Tip If you are using RSLogix 500 Standard, the source control feature is 
not available in the software.
If you are using RSLogix 500 Professional, you can install the source 
control features.  See Installing the source control feature on page 5 for 
information about installing the feature.  The source control feature 
requires that you run the software under Window 2000 or Windows 
XP.
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Registering the source control database with the 
administration utility
Registering the source control database lets the administration utility know 
what database it is supposed to administer.  To register the source control 
database with the administration utility:
1. Click Start > Programs > Rockwell Software > RSMACC Server > 

RSMACC Archive Administration Utility.  This starts the Archive 
Administration Utility.

2. In the utility’s window, click RSMACC Archive Module Databases.
3. Click Action > New > New Database Registration.  This displays the 

New Server Registration window.
4. In the New Server Registration window, choose your computer from the  

Server drop-down list.  Type the name of the Archive database in the 
Database field.

5. Click OK.  The Archive database appears in the navigation tree.  Right-
click the database, then click Connect.  If you get an error, it is likely that 
you misspelled the name of the Archive database.  In this case, right-click 
the database, select Properties, and re-enter the database name.

Creating database users
To create a database user with the Archive Administration Utility:
1. Log into the computer using an account that has administrative privileges.
2. Click Start > Programs > Rockwell Software > RSMACC Server > 

RSMACC Archive Administration Utility.
3. Open the Archive database.
4. Click the Users folder.  The utility displays a list of the currently defined 

users for the database.
5. Right-click the Users folder, then click New Login.  The utility displays 

the Add new database login window.  
6. In the Username field, enter the name of the user or user group you want 

to add.  You can browse for the name by clicking the browse button next 
to the field.

7. In the Domain field, enter the domain that authenticates the user or 
group (if you browsed for the user name, this field fills automatically).

8. Select the database role for the user.  Normal user means that the user or 
group cannot modify folder privileges.  User can modify folder rights
means that the user or group can change folder access rights for other 
users (the user or group has administrative access to the database).
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Assigning folder privileges to users
To assign folder privileges with the Archive Module database utility:
1. Log into the computer using an account that has administrative privileges.
2. Click Start > Programs > Rockwell Software > RSMACC Server > 

RSMACC Archive Administration Utility.
3. Open the Archive Module database.
4. Click the Folder Rights folder.
5. When you click the Folder Rights folder, the display shows the folders 

available in the archive (this should be only the File Repository folder at 
first).  Click the File Repository folder.  To the right of this folder, you 
will see a set of users and checkboxes.  The checkboxes are privilege 
settings for the folder.  

1. Click the
Folder Rights
folder

2. Click the folder for
which you want to set
privileges

3. Set the
privileges for
the folder
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6. Click the checkboxes corresponding to the permissions you want to grant 
to the users.  

Registering the source control database with 
RSLogix 500

Before you can use the source control functions of RSLogix 500 Professional, 
you must register the source control database with RSLogix 500.  Registration 
lets  RSLogix 500 know how to access the archive.
To register the database:
1. In RSLogix 500, click Tools > Source Control Utility.  This opens the 

Archive module tool.
2. In the Archive tool, click Database > Server Registrations.
3. The Manage Server Registrations window opens.  Click Add New.
4. In the Server Location field, enter the computer name.  You can browse 

for the name by clicking the down arrow button next to the field. 
5. In the Database Name field, enter the name of the Archive database.

This checkbox: Means:

I Inherit permissions from the parent folder.  The top level 
folder (File Repository) cannot have this setting.  If you 
choose this setting for a folder, no other setting is available 
for that folder.  By default, any folder you create inherits 
its permissions from its parent folder.

R Read.  The user can read files contained in the folder.

C Check in/Check out.  The user can check files into and out 
of the folder.  This setting implies the R permission.

A Add/Remove/Delete.  The user can add files to and delete 
files from the archive.  This setting implies the R and C 
permissions.

D Destroy.  The user can destroy files (deleting them does 
not remove them permanently from the archive).  This 
setting implies the R, C, and A permissions.
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6. Click Accept.  This registers the server.  

Adding a project to the archive
When you want to perform source control on an RSLogix 500 project, you 
must add it to the source control archive.  Once it is added to the archive, you 
can then track the modifications people make to it.
To add a project to the archive:
1. Open the project you want to store in the archive.
2. Click File > Source Control > Add Project to Source Database.  The 

software logs into the default Archive database and displays the Select
folder in which to add file window.  This window allows you to select or 
create a folder into which you want to save the project.

3. If you want to store the project in a previously created folder, double-click 
the folder to open it, then click OK.  If you want to create a new folder 
into which to store the project, click Create New Folder.  (If you cannot 
create a new folder or store a new project, it is because you do not have 
the access rights necessary to do so.  See your RSMACC administrator for 
more information.)

1. Click Add New.

2. Enter or select the
database server that
hosts the Archive
database.

3. Enter the name of the
Archive database.

4. Click
Accept.
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“Getting” and checking out projects
There are two ways to open a project that is stored in the Archive database.
You can get the project, which opens a read-only copy of the project for 
viewing, or you can check out the project, which opens a writable copy of the 
project so you can modify it.  Only one user can check out a project at one time.  
If you check out a project, no one else can check it out until you check it in.
Other people can get the project while you have a project checked out, but no 
one else can modify it.
To get or check out a project:
1. In RSLogix 500, click File > Open.  This displays the Open/Import 

SLC500 Program window.
2. In this window, click the Source Control tab.  This displays the source 

control options for getting or checking out projects.
3. Select the project you want to check out.

If nothing appears in the Open/Import SLC500 Program window, there 
are two possibilities:
a. The Archive database is not registered.  The database much be 

registereed before you can use the source control features of RSLogix 
500.  See See Registering the source control database with RSLogix 500 on 
page 66 for more information.

b. You need to log onto the Archive database. click the Login icon to 
select an Archive database.  (The Archive database must be registered 
before you can select it.)  The Login icon looks like this:

4. Choose whether you want to get or check out the project by clicking the 
Get or Check Out buttons.  

The Login icon
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5. Click OK.

6. The Get window or Check Out window opens (depending on whether 
you chose to get or check out the project).  
a. Enter the path to which you want to get or check out the project in 

the To field.

2. Select the project you want to
get or check out.

1. Click the Source
Control tab.

3. Select whether you want to get
or check out the project.

4. Click OK.
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b. If you are getting the project, you can make the project writable by 
checking the Make Writable box.  If you are checking out the 
project, you can check it out without copying the project to your 
computer by checking the Don’t get local copy box.

c. In the Action comments field, enter a comment regarding what you 
intend to do with the project.

d. Click OK.  The project is copied to your computer (unless you 
checked out a project without getting a local copy), and the project 
opens.

Undoing a check out
Undoing a check out resets the “checked out” flag on the project in the 
database, allowing other users to check out the project.  Changes you made to 
the project while it was checked out are not saved to the database when you 
undo the check out.
To undo a check out:
1. Click File > Source Control > Undo Check Out.
2. The Undo Check Out window appears.  

a. If you want to simply undo the check out, type a description of why 
you are undoing the check out in the Action Comments field, then 
click OK.

b. If you would like to undo the check out to a different source control 
database, click Change Location.  You can then select a different 
database into which to undo the check out.  (This works only if you 
have checked out the project from more than one database.).

Tip Check the Don’t get local copy box  if you want to keep other users 
from checking out a project or if you have performed a get on a 
project, made changes, and want to save the changes you made in the 
archive.
If you choose to check out a project without getting a local copy, and 
you do not already have a local copy of the project on your 
computer, RSLogix 500 creates a new project with the same name as 
the project you checked out.
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Checking in projects
When you check in a project, the project file stored in the database is 
overwritten with the project file you have checked out.  The changed project is 
then available for other users to check out.
To check in a project:
1. Click File > Source Control > Check In.
2. The Check In window appears. 

a. To simply check in the project, type a description of your changes to 
the file in the Action Comments field, then click OK.

b. To save the project in the database but keep it checked out, check the 
Keep Checked Out box before clicking OK.

c. If you want to change the database into which you are checking in the 
project, click Change Destination.  You can then select a different 
database into which to check in the project.  (This works only if you 
have checked out the project from more than one database.)
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Introduction
Use this chapter to review the sources of additional information on RSLogix 
500 software, including online help, RSLogix 500 training, and technical 
support.
You can find out more information about RSLogix 500 software by consulting:

RSLogix 500 online help
RSLogix 500 training
Technical support services

RSLogix 500 online help
RSLogix 500 online help provides general overview information, a description 
of the fields on every dialog box, and step-by-step procedures for working with 
all of the features of RSLogix 500. To open online help while running RSLogix 
500 you can:

choose Help from the menu on the RSLogix 500 main window
click the Help button on any RSLogix 500 dialog box
press F1 on any instruction, dialog box, or window view
expand the Help folder in the project tree and then double-click on any 
informative file listed to launch a help file.

Chapter Getting the information 
you need
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Opening an expandable table of contents
To open an outline of the entire RSLogix 500 online help system:

click Help on the menu bar and then click Contents
click the Help folder in the project tree and then double-click Contents

Index
The index tab provides a list of guide words or subjects just like the index of a 
book. This is a quick way to find information about a specific topic. Follow the 
directions on the Index tab.

Find
If you don’t see what you are looking for in the contents or index, you can 
search the entire help file for all occurrences of a word. follow the directions 
on the dialog to find a word.
The first time you click the find tab you will see a message about building a 
word list. Follow the directions on the screen. The default selection is generally 
sufficient. For information refer to Microsoft’s online help (Start > Help).

Double-click any 
closed book icon 
to reveal the 
content.

To collapse the
outline, double-
click an open 
book icon.

To go to a topic 
double-click a 
page.

Double-click the 
procedures book 
to see a list of
 tasks you can 
accomplish using
any function of 
the software. 



Getting the information you need • 75

Learning RSLogix 500 step-by-step

In Help you will find a Step-by-Step topic that asks what you want to do and 
lets you select from many of the tasks you might want to perform. 
To quickly step through the major tasks associated with creating a project, 
going online, and monitoring data, click on the check boxes. If you want more 
information about some of the other things that you can do associated with a 
major task, click the specific procedure.

Click this book icon to get more
background reference material
associated with any procedure.

Once you have completed reading the 
“How To” window, you can select
another task from this list.
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Quick tips about Windows operating systems and 
RSLogix 500

Windows operating systems provide some functionality you may not be 
familiar with. The RSLogix 500 online help can point out some shortcuts and 
navigational techniques that can make your work easier. Just select 
Understanding the Operating Environment from the contents page of the 
online help. 

Keyboard shortcuts
A list of hot keys (keyboard shortcuts) that enable you to maneuver the 
software without a mouse can be found in a help file that you can print out. To 
access this file, select Help > Using the Keyboard. To print any of the 
keyboard help topics, just click the Print button at the top of the window.
Some of these keyboard shortcuts (sometimes called Ctrl-key accelerators) are 
standard to the Windows operating system and work across all Windows-based 
products. Other shortcuts will only work with the RSLogix 5 and 500 products.

User Application help
The User Application Help feature allows you to add your own reference 
source (document, web page, etc.) to the RSLogix 500 project. You can use 
whatever format you want for the source as long as the computer running 
RSLogix 500 can open and read that source. For example, you could use a 
Microsoft Word .Doc file, provided that you had Word on your computer. Or 
you could use an HTML file if you had a browser that could read the file.
Your User Application Help file is saved with the project in RSLogix 500. You 
can specify one User Application Help file per project.
To set up your User Application Help file:
1. Create the source file for your User Application Help.
2. From the project tree in RSLogix 500, right-click User Application Help

(under the Help folder) and select Properties. The User Application 
Help dialog appears.

3. Enter the path and file name (you can Browse for the file), or the URL for 
your source file and click OK.

To specify a different source file, go back to the Properties dialog and enter the 
new path and name.
To display the User Application Help file, double-click on User Application 
Help (under the Help folder in the project tree) or click Help > User 
Application Help from the main toolbar menu.
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Instruction Set help
All of the instructions available to you in RSLogix 500 have context-sensitive 
help. You can click an instruction in your ladder logic for help about the 
parameters required or for information about why you might use one type of 
instruction instead of another.
Each topic in the instruction set online help also gives you information about 
which processors can use the instruction and an example of the instruction with 
sample parameters. 

RSLogix 500 Training
Rockwell Software offers both classroom and computer-based training for 
RSLogix 500.

Classroom training
One of the best ways to increase your proficiency at using Rockwell Software 
products is to attend a Rockwell Software training program. Our training 
programs can help you master the basics and show you how to unleash the full 
potential of our software.
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We offer a wide range of training programs, from regularly scheduled classes 
conducted at Rockwell Software facilities to custom-tailored classes conducted 
at your enterprise. The size of each class is kept small intentionally to maximize 
student engagement.
For more information about our training programs:

visit our web sit at http://www.software.rockwell.com/training/
view the Support and Training help file either from Help on the menu bar 
or from the Help folder in the project tree.
contact the Rockwell software Training Coordinator at 877-724-7864.

Interactive training
Rockwell Software's new RSTrainer 2000 Self-Paced Training programs 
provide multimedia lessons and interactive practice exercises designed with 
student objectives in mind. Features include animated graphics, professional 
audio and content written by Rockwell Training and Tech Support Specialists. 
Courses are based on the latest shipping release of the software product and 
include links to the software help files.
RSTrainer 2000 for RSLogix 500 contains four lesson modules and over 35 
individual multimedia lessons. You’ll learn to install and configure RSLogix 500 
and to use it’s powerful features to efficiently develop and maintain ladder logic 
programs.
A demo of the training program is included on the RSLogix 500 CD-ROM. To 
run the demo, insert the RSLogix 500 CD_ROM into the CD-ROM drive. 
When the menu appears, select Try RSTrainer 2000 for RSLogix 500.
If the CD-ROM does not autorun, open the Start menu and select Run. Type 
x:\autoplay (where x is your CD-ROM drive), and click OK. Select Try
RSTrainer 2000 for RSLogix 500 from the menu.

Technical support services
If you cannot find answers to your questions in this publication or in the online 
help you can call Rockwell Software technical support.
Telephone: 440-646-7800
Fax: 440-646-7801
World Wide Web: http://www.software.rockwell.com/support/
Support staff are available Monday through Friday 8 a.m. to 5 p.m. EST, CST, 
MST, and PST, except during U.S. holidays.
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When you call
When you call you should be at the computer running the Rockwell Software 
product and be prepared to provide the following information:

product serial number on the Activation disk labels (You can find the serial 
number online. On the RSLogix 500 menu, click Help, and then click 
About.)
product version number
hardware you are using
Microsoft Windows operating system and service pack you are using
exact wording of any messages that appear on the screen
description of what happened and what you were doing when the problem 
occurred
description of how you tried to solve the problem
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Rockwell Software’s products are copy-protected. Only a computer with access 
to the activation key can run the software. The key is located in an activation 
file, which is originally located on the Master disk supplied with the RSLogix 
500 product. The activation file contains one activation key per product. Each 
key contains one or more licenses depending on how many copies of the 
product you have purchased.

During the setup process, the setup program gives you the opportunity to 
move the activation file from the Master disk to the root folder of the drive on 
which you’re installing the software.
When you launch RSLogix 500, the software first checks your local hard drives, 
then network hard drives, and finally local floppy drives for activation. If the 
system fails to detect either the activation file or the Master disk, you will 
receive an error message stating that activation is required to run the RSLogix 
500 software.

Appendix Activation

Store your Master disk in a safe place. If your activation becomes 
damaged, the Master disk may be the only means to run your 
software in an emergency.

Systems attached to extensive networks can take quite a while to 
search for activation files on all available drives. You can use the 
CHECKDRIVES environment variable to specify and/or limit 
the drives your software checks for activation files and to specify 
the order in which they are checked. Refer to the activation 
utilities online help file by selecting Help > Copy Protection.

Tip

Tip
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Protecting your activation files

To avoid damaging your activation files, do not perform the following 
operations with activation files on the hard drive. 

Restore from backup
Upgrade the operating system
Compress or uncompress the hard drive 

Defragmentation utilities will not harm activation files.
Before running any type of utility that may modify the structure or organization 
of the hard drive, remove activation from the hard drive:
1. Use the Move Activation utility (EvMove) to move activation files from 

the hard drive to an activation disk.

Run EVMOVE.EXE from your hard drive (located in C:\Program 
Files\Rockwell Software\RSUtil if you accepted the default folder location 
during installation).

2. Perform the hard disk operation.
3. Move the activation files back to the hard drive.

Activating RSLogix 500
Depending on your needs, you can activate RSLogix 500 from any of the 
following:

Certain anti-virus software packages, such as Norton Anti-virus, 
can corrupt the activation files. Configure your anti-virus 
software to avoid checking the files EVRSI.SYS and 
386SWAP.PAR.

Caution

Do not use the the Move Activation utility if Rockwell Software 
products are currently running. Ensure all software programs are 
closed before initiating the EvMove utility.

Caution

You must use the move utility, EvMove, to move activation files. 
Attempts to copy, move or e-mail an activation file by other 
means will damage the file.

Caution
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Hard drive.Hard drive.Hard drive.Hard drive. The activation key resides on your computer’s hard disk. Use this 
method if you will typically use RSLogix 500 on only one computer. This is the 
default method if you activate RSLogix 500 during installation. To run RSLogix 
500 on a different computer, move the activation key back to the Master disk, 
and then to the hard drive of the new computer.
Diskette drive.Diskette drive.Diskette drive.Diskette drive. The activation key resides on a floppy disk (activation disk). Use 
this method if you will typically use RSLogix 500 on more than one computer, 
for example, if you want to run RSLogix 500 on a desktop computer at some 
times and a portable computer at others.
Network drive.Network drive.Network drive.Network drive. The activation keys reside on a network drive. Use this method 
if you have purchased multiple licenses of the software and want several users 
to be able to activate the software over a network. Refer to the online help for 
instructions on moving activation to a network drive (refer to the “Finding 
more information about activation” section in this chapter to access online 
help).

Running the activation utilities
The utilities for moving and resetting activation are called EvMove and Reset 
respectively. Reset is used when an activation file has been damaged. The 
EVMOVE.EXE and RESET.EXE files are located on your hard drive (located 
in C:\Program Files\Rockwell Software\RSUtil if you accepted the default 
folder location during installation). To run these programs, select Start > 
Progams > Rockwell Software > Utilities > Move Activation or Reset
Activation.



84 •  Getting Results with RSLogix 500™

Finding more information about activation
The online help (COPYPROT.HLP) provides more extensive information on 
activation including subjects such as:
KEYDISKKEYDISKKEYDISKKEYDISK. Set this environment variable to tell your computer to look for 
activation on floppy drives
CHECKDRIVESCHECKDRIVESCHECKDRIVESCHECKDRIVES. Specify which drives to search for activation
network activationnetwork activationnetwork activationnetwork activation. Move activation to a network server to allow multiple 
users access to the activation
moving activationmoving activationmoving activationmoving activation. See detailed instructions for moving activation
resetting activationresetting activationresetting activationresetting activation. See detailed instructions for using the Reset utility to 
repair a damaged activation file
troubleshootingtroubleshootingtroubleshootingtroubleshooting. Look up error messages, get problem-solving suggestions
You can access online help:

from the Help button on one of the EvMove or Reset dialog boxes.
from RSLogix 500 by selecting Help > Copy Protection from the main 
menu.
without running either RSLogix 500 or the activation utilities. From the 
Windows Start menu, select Programs > Rockwell Software > Utilities > 
Activation Help (if you accepted the default folder location during 
installation).

Some common questions
Following are some common problems that people encounter with activation 
and their solutions.

My activation files were damaged. What should I 
do?
If you have lost the activation because the activation file is damaged, you need 
to reset activation. Follow the Reset Codes instructions on the Rockwell 
Software Technical Support web page, or call the technical support telephone 
number. The web page and telephone number are both listed on the inside 
front cover of this guide.
If you cannot obtain a reset code immediately, follow these instructions to use 
the Master disk to activate the software as a temporary solution.
To use the Master disk to activate software:
1. Set the KEYDISK environment variable to TRUE. (Please refer to the 

online help.)
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2. Insert your Master disk in the floppy drive.
3. Run your software as usual. Your software will find the activation on the 

Master disk.

I accidentally deleted the software folder on my 
hard drive. Do I need to call Rockwell Software for 
replacement activation files?
No. Deleting the program files does not delete your activation. The activation 
files are not stored in the program folder; they are located in the root folder. 
Your activation files will not be lost unless you format the hard drive, tamper 
with hidden files in the root folder, or perform certain other hard drive 
operations (refer to the “Protecting your activation files” section in this chapter 
for more information).
To get the software running again, simply reinstall the software, but do not 
move the activation when given the opportunity.

Why can’t I move activation to a new floppy disk on 
a Windows NT system?
It has to do with a disk modification that NT does not allow. If you have access 
to a Windows 95 or 98 machine, you can create a disk that will work under NT. 
Format a floppy and move any activation file to it under Windows 95 or 98. 
(You can move the activation back off the disk if you want to keep it where it 
was.) Then take that disk to your Windows NT machine and move the 
activation to it.
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