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L’ambiente di sviluppo STEP 7

STEP 7 ¢ il pacchetto software per sviluppare progetti di automazione basati sui prodotti
Siemens della serie SIMATIC [1].

| progetti sono costituiti dall'insieme dei dati e dei programmi di una soluzione di automazione.
In particolare un progetto contiene:
e dati di configurazione relativi alla struttura hardware e dati di parametrizzazione
per le unita;
e dati progettazione per le comunicazioni di rete;
e programmi per le unita programmabili.

Il sistema di sviluppo &€ composto da un software di base e da un numero di componenti
aggiuntivi, eseguibili su piattaforme Windows.

Con il pacchetto base di STEP 7 ¢ possibile:

» creare e gestire progetti;

» configurare e parametrizzare lhardware e le comunicazioni dei sistemi di
automazione;

> creare programmi per i PLC delle serie SIMATIC S7 (per sviluppare software per i
PLC della serie M7 & necessario installare un componente aggiuntivo);

» caricare i programmi nei sistemi di destinazione;

» validare il software sviluppato.

Nelle pagine successive verra presentata la versione 5 di questo prodotto e verra fatta una
breve descrizione dei linguaggi di programmazione messi a disposizione dell'utente (il
linguaggio a contatti KOP, la lista di istruzioni AWL, I'SCL, ecc.). Per approfondimenti si
rimanda alla documentazione della casa produttrice [2-8].
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1 - Creazione di un nuovo progetto e configurazione hardware

Dopo aver installato STEP 7 sul proprio PC, nel menu Avvio di Windows comparira la cartella
SIMATIC. Al suo interno si trovano le licenze, i manuali e le varie applicazioni di STEP 7
installate.

Le applicazioni disponibili nel pacchetto base di STEP 7 sono:

Pacchetto di base

. s ; NETPRO
Editor di simbali SIMATIC Manager Configurazione della
comunicazione
Configurazione | |Linguaggi di programmazions Diagnostica
hardware KOP | FUP | MWL hardware

Figura 1 - Step 7, software di base

SIMATIC Manager consente di creare e gestire i dati di un progetto d’automazione; le
applicazioni necessarie per la modifica di un tipo di dati vengono avviate automaticamente da
SIMATIC Manager.

Una volta mandato in ese@zione SIMATIC Manager & possibile creare un nuovo progetto
selezionando File>New...1.

La finestra che compare é divisa in due: nella parte sinistra viene visualizzata la struttura del
progetto in maniera analoga alla struttura di una directory di Windows, mentre nella parte destra
viene visualizzato il contenuto dei singoli componenti.

Si noti nel nuovo progetto risulta gia presente la rete MPI, per la quale, perd, non & definito
alcun nodo, essendo il progetto vuoto.

QSIHATIE Manager - new

File  Edit PLC Miew DOptionz Window Help
1 SIMATIC 400 Station
Subnet » 2 SIMATIC 300 Station
Program » JSIMATIC H Station
4 SIMATIC PC Station

| < Mo Filter >

F
g; :;:uft'.-_:are ) & Other station
M?EDE . BSMATICSS
el 7 PG/PC

Sl Tiable
Exfermal Saunee..

Figura 2 - new project

" nel seguito si usera la notazione File—>Save per indicare la selezione dell'opzione Save nel
menu File.
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Questa presenza ¢ giustificata dal fatto che la rete MPI (rete proprietaria Siemens) € I'unica
rete alla quale € possibile collegare un PLC Siemens non ancora configurato.
Solo attraverso MPI, quindi, & possibile caricare la configurazione hardware in una CPU.

Facendo clic sulla cartella del progetto ed entrando nel menu Insert € possibile inserire nel
progetto:
» una stazione SIMATIC;
» un’altra rete di comunicazione;
» un programma (S7 oppure M7).

Si noti che si pud inserire un programma senza aver definito la stazione sulla quale andra in
esecuzione; & necessario, invece, definire la stazione di lavoro se si vuole caricare il software
sviluppato sul PLC oppure se si vuole utilizzare il simulatore.

Se si desidera inserire un PLC della serie S7-400 selezioniamo Insert-> Station—-> SIMATIC
400 Station e gli si assegni un nome (nell'esempio di fig. 3 € stato scelta il nome Testata; per
rinominare gli oggetti basta selezionarli e premere F2).

A questo punto nella cartella del progetto comparira il simbolo della stazione.

In maniera analoga € possibile inserire altre reti di comunicazione che fanno parte del sistema
di controllo (per esempio reti Profibus e Industrial Ethernet).

HSIHATIE Manager - [851 - Saltan -- DASIEMENSAS TEPAAS 7projinew]

% File Edit Inzert PLC “iew Options ‘Window Help

D||}|§“|ﬁ| e = e [ < NoFiker » =1
Object name | Symbalic name | Type
B I TESTﬂTﬁ BE TESTATA SIMATIC 400 Station
TEMPIN) MPI
TEPROFIBUS) PROFIBLS
? Ethernet[1] Industrial Ethernet

Figura 3 - Stazione SIMATIC 400

Selezionando la stazione, sulla destra compare I'icona Hardware.

% File Edit |nzett PLC Yiew QOption: indow Help
D|(88)7| & (e bl [= =
B- % 251 - Saltan Object name
""" G TESTATA Bl Hardware

Figura 4 - Icona Hardware

Facendo doppio clic su quest’icona viene richiamata I'applicazione HW Config con la quale
¢ possibile configurare I'nardware della stazione:
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[li HW Config - TESTATA

Station  Edit  Inzet PLC View Option: Window  Help

O[cz(z-2 =] & =lel ﬁIwIEIiEI_I

AMTESTATA [Configuration] -- 851 - Saltan

Profile I Standard

%! FROFIBUS DP

=-F SIMATIC 300

SIMATIC 400

SIMATIC PC Based Control 2004400
=B, SIMATIC PC Station

Figura 5 - HW Configuration

Sulla destra & presente il Catalogo hardware dal quale si possono selezionare i componenti
che compongono la stazione. Nel caso il catalogo non appaia & sufficiente selezionare
Insert->Hardware Components.

Nella finestra a sinistra (Configuration) comparira la struttura della stazione mano a mano
che essa verra definita.

Per portare un oggetto dalla finestra di destra a quella di sinistra & sufficiente utilizzare il
drag&drop.

In STEP 7 le unita vengono collocate su telai di montaggio (rack), proprio come in un impianto
reale. L'unica differenza consiste nel fatto che i telai vengono rappresentati mediante tabelle di
configurazione, caratterizzate da un numero di righe pari a quello delle unita inseribili nel telaio
di montaggio reale.

Il primo passo, quindi, & la scelta del rack. Per il nostro esempio inseriamo un UR1 (Universal
Rack). Nella parte inferiore della finestra del catalogo, compare una breve descrizione del
componente selezionato.

A questo punto, tenendo conto della configurazione della stazione di Testata riportata in fig. 6,
si possono inserire le varie unita negli slot del telaio.
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Alimentatore 10 A 120-230 V Ac
Unita Centrale CPU 414-2-DP
Interfaccia seriale CP 441-1
Interfaccia ethernet CP 443-1
Modulo 32 Ingressi Digitali 24 VV Dc
Modulo 32 Ingressi Digitali 24 VV D¢
Modulo 32 Ingressi Digitali 24 VV Dc
Modulo 32 Ingressi Digitali 24 VV Dc
Modulo 32 Ingressi Digitali 24 VV Dc
Modulo 32 Ingressi Digitali 24 VV Dc
Modulo 32 Ingressi Digitali 24 VV Dc
Modulo 32 Uscite Digitali 24 V Dc
Modulo 32 Uscite Digitali 24 V Dc
Modulo 32 Uscite Digitali 24 V Dc
Modulo 32 Uscite Digitali 24 V Dc
Modulo 32 Uscite Digitali 24 V Dc

Figura 6 - Configurazione della stazione di Testata
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Appena si inserisce il modulo processore (CPU 414-2 DP) viene chiesto di impostare
lindirizzo Profibus dell'unita; premendo il pulsante Properties si puo scegliere la velocita di
trasmissione della rete (vedi fig. 7).

i'_ FProperties - PROFIBUS interface DP Master (R0/53.1) E3
i General Parameters |
Address: IE 'l If & subnet iz zelected,

the next available address is suggested.
Highest address:126

Transmizzion rate:1.5 Mhbit/s

Subnet;

,‘S‘ - nok networked --- ] Mew..
FRAOFIBUS(1] 1.5 Mbit/z

- Fraperties. . |
[Elete |
ibh

Figura 7 - Finestra di dialogo per 'inserimento dell'indirizzo Profibus della CPU 414-2
DP

Nella parte inferiore della finestra di configurazione e presente un riepilogo dei parametri per
ogni unita inserita.

Selezionando ogni unita & possibile impostare dei parametri semplicemente premendo il tasto
destro del mouse e selezionando Object Properties.... Per esempio & possibile definire gli
indirizzi per le unita di ingresso/uscita digitali.

Si pud anche definire, nelle proprieta della CPU, un byte della memoria utente (memoria di
merker) come byte di clock (vedi fig. 8).

Properties - CPU 414-2 DP - [R0D/53)

Tirne-of-01ay Interupts l Cuclic Intermipt | Diagnoztics/Clock | Frotection
General i Startup CycleClock Memary I Fetentive Memarny i b ernory I Intermipts

—Cycle

v Update Process Image Cyclicallé

Scan Cycle Monitoring Time [ma]: 150

Finimum Scan Cycle Time [ms]: !EI
Scan Cycle Load from Communication [%]: IEEI

Size of the process-image input area 256

Size of the Procezz-lmage Output Area |255

0B85 - Call Cess Ermor ch individual access _:j

f‘ﬁ;ck kdernony \

¥ Clock Memary
;2

temary Byte:

Cancel Help

Figura 8 - Byte di clock
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|l programmatore, quindi, avra a disposizione 8 clock a frequenze diverse (uno per ogni bit);
questi segnali possono essere utili quando si vuol far lampeggiare una lampada oppure far
suonare una sirena ad intermittenza.

Una volta inserito il modulo processore compare il simbolo della rete Profibus, quindi si
possono inserire tutte le unita collegate al PLC Testata mediante questa rete.

fiiii (0] IR

1

PS 407 104

FY

CPU 414-2 DP

LF AR 3efar

PROFIBUS[T): DP master system [1]

AEEAE

CF 441-1

CF 4431

DI32:DC 244

DI32:DC 24%

DI32:DC 24%

gl A= Wl s )

DI32:DC 24%

1]

LR1

b oduile

Order number

MPl addrezs

| address

[ addrezs

Comm

Slat
3

PS5 407 104

BESY 407-0KADT-02440

CPU 414-2 DP

GEST 414-Z{G03-04B0

LF A 3efar

FrE7

AL

ST

CF 441-1

BESY 441-12403-04E0

8183

CF 4431

BGKY 443-1EX02-0<ED

8133

DI32:DC 24%

EESY 421-1BLO0-04A0

0.3

DI32:DC 244

EESY 421-1BLO0-04A0

4.7

Figura 9 - PLC di Testata
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Una volta completata la configurazione hardware, dovra essere compilata per verificarne la
correttezza.

Se la compilazione va a buon fine ed il PC & collegato con il PLC, si pud caricare la
configurazione fatta nella CPU.

Se si ha a disposizione la stazione gia montata e collegata al PC si pud caricare la
configurazione direttamente selezionando I'opzione PLC>Upload to PG; a questo punto si
potranno settare tutti i parametri (per esempio gli indirizzi Profibus) e poi caricare di nuovo il
tutto nel PLC.

Creare una stazione

~ -

Richiamare I'applicazione
"Configurazione HW"

~ >

Disporre i telai di montaggio
(rack)

<

Disporre/Inserire le unita

<~

Definire le proprieta delle
unita

~ >

Salvare e compilare la
configurazione

~

Caricare la configurazione nel
sistema di automazione

Figura 10 - Configurazione Hardware

In fig. 10 ¢ riportata la sequenza di operazioni necessarie per configurare una stazione
SIMATIC.

A questo punto in SIMATIC Manager, nella stazione Testata, saranno presenti i moduli
processore definiti in precedenza e, al loro interno, ci saranno dei programmi vuoti.

HSIHATIE Manager - [851 - Saltani -- D:ASIEMENSASTEP7AS

%Eile Edit Inzet PLC “iew DOption: Window Help

s EEEEEE e

BRET}CFL 4142 DP
¢ =7 Programma 57

--:{]: CF 4431

% 897 - Salkan Object name
E-Fl TESTATA Programma 57

ﬁﬁ Conrections

Figura 11 - Programma S7
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In ogni programma sono presenti due cartelle: una con i sorgenti del codice a laltra
contenente i blocchi eseguibili che dovranno essere caricati nel controllore.

Alcuni linguaggi (AWL, KOP e FUP) permettono di creare dei blocchi che possono essere
caricati direttamente nel controllore senza dover essere compilati, mentre con altri linguaggi
(SCL) si possono scrivere solo programmi sorgente.

2 - Struttura dei programmi S7

Nella CPU dei PLC vengono eseguiti due programmi distinti:
» il sistema operativo;
» il programma utente.

Il sistema operativo (s.0.) & presente in tutte le CPU e organizza tutte le funzioni e le
procedure che non sono legate ad un compito di controllo specifico. E il s.0. che realizza la
modalita di funzionamento chiamata ciclo a copia massiva degli ingressi e delle uscite, ovvero:

e aggiorna I'immagine di processo degli ingressi;

e esegue il programma utente, operando sui valori della memoria e conservando
I risultati sempre in memoria;

e esegue i programmi di gestione del sistema;

e scrive l'immagine di processo delle uscite.

L’immagine di processo € una copia degli ingressi e delle uscite che viene conservata in
un’apposita area di memoria del controllore. Il programmatore, quindi, non accede direttamente
alle unita di I/O, bensi a quest'area di memoria dedicata.

| programmi di gestione si occupano di:

o rilevare gli allarmi e richiamare i segmenti di codice da eseguire in caso di
allarme;

e gestire la memoria;

e riconoscere e gestire gli errori;

e gestire la comunicazione con i dispositivi di comunicazione e gli altri nodi della
rete.

In realta per i controllori della serie S7 I'ordine delle operazioni effettuate nel ciclo & differente,
infatti per questi controllori il s.0.:
o avvia il tempo di controllo ciclo;
o scrive 'immagine di processo delle uscite nelle unita di uscita;
o legge lo stato degli ingressi nelle unita d’ingresso e ne aggiorna I'immagine di
processo;
o esegue il programma utente;
o esegue i programmi di gestione del sistema.

Il tempo di ciclo € il tempo che richiede il s.o0. per effettuare il ciclo a copia massiva. Questo
tempo non deve essere superiore ad un valore massimo che € possibile impostare, e viene
controllato dal s.0. ad ogni scan.

Se questo tempo massimo viene superato la CPU va in STOP, oppure viene richiamato un
segmento di codice particolare nel quale si puo stabilire la modalita di reazione della CPU
all'errore di tempo.

Il programma utente deve essere creato e caricato nella CPU. Questo programma contiene
tutte le funzioni necessarie per risolvere il problema di automazione considerato.
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STEP 7 offre la possibilita di strutturare il programma utente, ovvero di suddividerlo in singole
sezioni indipendenti, ottenendo i seguenti vantaggi:
e e singole parti del programma possono essere standardizzate;
e lorganizzazione del programma viene semplificata;
¢ |e modifiche del programma si possono eseguire piu faciimente;
e la semplificazione del testing e della validazione del programma, poiché
possono essere eseguiti per sezioni;

Con STEP 7 il programmatore ha a disposizione dei blocchi elementari attraverso i quali puo

strutturare il software; questi blocchi possono essere divisi in due gruppi:
e blocchi di codice;
e Dblocchi di dati.

Esiste un numero massimo di blocchi inseribili per ogni tipo e questo limite varia a seconda
del modulo processore utilizzato.

Ogni tipo di blocco pud essere inserito come sorgente in un opportuno linguaggio di
programmazione oppure come blocco direttamente eseguibile e caricabile nella memoria del
controllore.

Per poter inserire un blocco eseguibile in un programma S7 bisogna aprire la cartella Blocks
nella finestra destra di SIMATIC Manager, e selezionare I'opzione Insert->S7 Block. Se,
invece, si vuole inserire un sorgente bisogna selezionare Insert->S7 Software, dopo aver
cliccato sulla cartella Sources.

Statiar _
Submet F
Eragram F

S Sathnane F
ck. 1 Organization block:
i Eattivare r 2 Function block,

3 Function
E_I,_Itmb':" lTSat'lE 4 Data block
AL e S Data type
& *ariable table

'53?1‘:851 - Saltari -- DASIEMENS S TEF fua spropinew el m] B4
-8 851 - Saltani

o-E TESTATA =t
|§|--- CPU 4142 DP BT
- [E+{z1] Programma S7 T
~{B Sources
%9 Blocks

- OF 4434

Figura 12 - Menu Insert->S7 Block

Quando si inserisce un blocco eseguibile, compare un’icona nella finestra destra di SIMATIC
Manager; facendo doppio click sull'icona il blocco viene aperto e SIMATIC Manager richiama
I'editor AWL, KOP e FUP; attraverso questa applicazione I'utente pud scrivere il codice é creare
strutture dati.
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2.1 - Blocchi di codice

Vi sono diversi tipi di blocchi di codice che possono essere utilizzati all'interno di programmi
utente S7 e sono riportati in Tabella 1.

Quando viene aperto un blocco di codice eseguibile, nell'editor compaiono due finestre:
quella superiore contiene le dichiarazioni delle variabili, mentre quella inferiore contiene il
codice (fig. 13). Il codice pud essere suddiviso in piu segmenti (network), per aumentare la
leggibilita.

ELADJSTLIFBD - [FC59 -- 851-5altar\TESTATANVCPU 414-2 DP(1]]

% File Edt |nset PLC Debug “iew Options ‘window Help
O3 E] 2| =2 o] vl o & 2

in_out

0. 0| enp Sequenzalk EOOL

FC59 @ Uscite Zona 1

Comment:

pRrmamma= ]

Hetwork 1@ Lampada YERDE [(AUTOMATICO)

[ I -

Comment:

"IbZona_1"
Zonalnidut

omatico "HL1A™

| | T |
[ L |

Hetywork 2 : Lampada GIALLA (MANTTALE)

Comment:

Figura 13- Editor KOP, FUP e AWL

Blocchi Organizzativi (OB)

Gli OB rappresentano l'interfaccia tra il s.0. e il programma utente. Questi blocchi vengono
richiamati dal s.0. € comandano l'elaborazione ciclica del programma su interrupt, il
comportamento del sistema di automazione all'avvio e la gestione degli errori.

Negli OB vengono richiamati gli altri blocchi di codice, determinando, cosi, la sequenza in cui
questi verranno elaborati e, quindi, il comportamento del controllore.

Ad ogni OB é associata una priorita che pud assumere un valore compreso tra 1 e 28;
I'esecuzione di un blocco organizzativo pud essere interrotta solo dal richiamo di un OB con
priorita piu alta.

Per alcune CPU (per esempio quelle della serie S7-400), 'utente pud modificare la priorita di
alcuni OB.

10
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Blocco Descrizione

Blocchi organizzativi (OB) Gli OB determinano la struttura del programma
utente

Funzioni (FC) Le FC contengono routine di programma

Blocchi Funzionali (FB) Gli FB sono blocchi funzionali con “memoria”

Blocchi Funzionali di Sistema (SFB) e Gli SFB e gli SFC sono integrati nella CPU e

Funzioni di Sistema (SFC) rendono accessibili alcune importanti funzioni
di sistema

Tabella 1 - Blocchi di codice

Il blocco OB1 viene richiamato dal s.0. ad ogni ciclo (scan).

E in questo blocco che andranno messe le chiamate agli altri blocchi del programma utente;
grazie allOB1, quindi, si implementa la modalita “normale” di funzionamento del controllore
programmabile.

L’'OB1 & come il main nel linguaggio C e quindi sara presente in ogni programma S7.

E possibile scrivere I'intero programma utente in questo blocco (programmazione lineare).
Questa operazione, perd, € consigliabile solo per programmi molto semplici. In generale é
conveniente avere diversi segmenti di codice in blocchi diversi, ognuno dei quali esegue una
funzione elementare (programmazione strutturata); nell OB1 saranno presenti solo le chiamate
a questi blocchi.

La priorita del’OB1 vale 1 e non pud essere cambiata dal programmatore. Esiste solo un
blocco organizzativo con priorita piu bassa ed & 'OB90 (la cui priorita €, per convenzione, 29).

Oltre al’OB1 ci sono altri blocchi organizzativi che vengono chiamati dal s.o. su eventi
speciali come un guasto nel rack di montaggio (OB86), il riavviamento del controllore (OB101)
oppure il superamento del tempo ciclo massimo (OB80).

L’OB100, invece, viene richiamato solo al primo scan.

Altri OB, come 'OB10, vengono richiamati periodicamente ad intervalli prefissati di tempo
impostabili dall'utente (OB a tempo).

In fig. 14 & riportato un diagramma temporale che mostra le chiamate del s.0. ad alcuni OB in
un tempo ciclo.

Funzioni (FC)

Una FC contiene un programma che viene eseguito ogni qualvolta essa viene richiamata da
un altro blocco di codice.

Per ogni funzione & possibile dichiarare dei parametri di ingresso, di uscita, di ingresso/uscita,
nonché delle variabili temporanee.

Quest'ultime vengono memorizzate nello stack dei dati locali e vanno perdute dopo
I'elaborazione dell’FC.

Non ¢ possibile assegnare alcun valore iniziale a nessun dei parametri di una funzione.

Per la memorizzazione dei dati, le funzioni possono utilizzare blocchi dati globali (DB).

11
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Tempeo di controllo del ciclo per le CPU finora in commercio

Ciclo attuale Ciclo successivo
1
e ™ -i
Riserva |
q TI|1II'|
PK16 (OB 40)
PKOT DB10) 10|
Aggiormamenta Aggiomamento Aggiornamento
PKO1 | dell IPI B IIOE” delllPU el 1P| OB1
PK29 GB% Dﬁeﬁ IDBo0

Tmax = Tempo di ciclo massimo impostatile

Tmin Tampo di ciclo minimo impostabile

Tz = Tampo di ciclo reala

Twait = Ladifferanzatra T, @ il tempo di ciclo effattive; in questo inftervallo di tempo sl possono
alaborare eventuall interrupt verificatisi @ I'OB di priorita bassa (OB 90)

PK = Classe dl priorita

Figura 14 - Tempo ciclo

Poiché le FC sono blocchi “senza memoria”, ogni qual volta se ne effettua la chiamata,
bisogna specificare i valori attuali dei parametri d’ingresso, di ingresso/uscita e i parametri
d’uscita.

Blocchi funzionali (FB)

Anche il codice contenuto in un FB viene eseguito ogni qualvolta I'FB viene richiamato da un
altro blocco di codice.

Un blocco funzionale € un blocco “‘con memoria”; esso dispone di un blocco dati correlato
(blocco dati di istanza), nel quale vengono memorizzati i valori delle varibili di ingresso, d'uscita,
d’ingresso/uscita e statiche.

La struttura del blocco dati di istanza corrisponde con le variabili statiche specificate nella
finestra di dichiarazione dell'editor KOP, FUP e AWL.

Nelle FB e possibile utilizzare anche variabili temporanee che, perd, vengono memorizzate
nello stack dei dati locali.

Al termine dell’elaborazione dell’FB, i dati memorizzati nel blocco dati di istanza non vanno
perduti, al contrario di quelli memorizzati nello stack dei dati locali.

Ad ogni variabile, tranne per quelle temporanee, € possibile assegnare un valore iniziale.

Ogni volta che un blocco funzionale viene richiamato, bisogna assegnargli il blocco dati di
istanza.

12
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Con il richiamo di diverse istanze di un FB si possono comandare piu apparecchiature con un
solo blocco funzionale. Per esempio, usando blocchi di dati di istanza differenti per vari motori,
una sola FB puo controllare pit motori.

Quando si effettua la chiamata di un FB non & necessario assegnare dei valori a tutti i
parametri del blocco; in questo caso verranno utilizzati i valori memorizzati nel blocco dati di
istanza.

Blocchi funzionali di sistema e funzioni di sistema (SFB, SFC)

Gli SFB e gli SFC sono blocchi integrati nelle CPU della serie S7.

Questi blocchi sono analoghi ai blocchi FB e FC e realizzano delle funzioni predefinite come
la copia di un area di memoria in un’altra, I'impostazione dell'orologio di sistema, l'invio di un
pacchetto di dati ad un nodo di una rete progettata, ecc.

4.2.2 - Blocchi di dati e la memoria utente

Prima di parlare dei blocchi di codice diamo qualche cenno sulla memoria utente dei
controllori S7.

Il programmatore pud accedere a sette diverse aree di memoria utente:
limmagine di processo degli ingressi (IPI);
Iimmagine di processo delle uscite (IPU);
I'area dei merker;
i blocchi dati;
lo stack dei dati locali;
I'area dei timer;

e [area dei contatori.

Le dimensioni di ognuna di queste aree dipendono dal particolare controllore. Tutte le aree

sono strutturate a byte anche se si pud accedere ai singoli bit di ogni byte.

Abbiamo gia visto che nelle aree IPI e IPU il s.o0. copia, ad ogni scan, lo stato dei moduli di
/0.

L’area dei merker € un’area tutta a disposizione del programmatore; non & possibile, da parte
dell'utente, definire una particolare struttura per quest'area di memoria.

| blocchi dati vengono memorizzati in un’apposita area di memoria. In questo caso l'utente
pud definire allinterno di ogni blocco delle strutture dati come gli array e i record, che in S7
vengono chiamati struct.

I programmatore, inoltre, pud anche accedere allo stack dei dati locali, dove vengono
memorizzate le variabili temporanee dei blocchi di codice.

Infine, nelle ultime due aree, il programmatore pud accedere direttamente a dei timer e a dei
contatori.

Per poter utilizzare nel codice un operando bisogna specificarne l'indirizzo oppure, come
vedremo in sequito, il simbolo associato.
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Un indirizzo € composto da un un prefisso, che specifica I'area di memoria alla quale si vuole
accedere, e da un numero che specifica 'indirizzo all'interno dell'area stessa.

Nel prefisso sono contenute informazioni anche sulla dimensione dell'informazione alla quale
si vuole accedere, cioé se si vuole leggere un singolo bit, un byte, una word oppure una doppia
word.

| prefissi per le varie aree sono riportati in Tabella 2.

Facciamo qualche esempio:

E0.4 - 5° bit del 1° byte dell'area di memoria degli ingressi

AW4 - word composta dal 5° e 6° byte dell'area di memoria delle uscite
DB100.DBX11.5 = 6° bit del 12° byte del blocco dati globali 100

LD5 - doppia word dai byte 6...9 dello stack dei dati locali

Nota: la generica word n & composta dai byte n (byte piu significativo) ed n+1 (byte meno
significativo). Analogamente la doppia word n & composta dalle word n (word piu significativa)
ed n+2 (word meno significativa).

Oltre ad accedere alle immagini di processo di ingresso e uscita, il programmatore S7 puo
anche accedere direttamente ai moduli di I/O, utilizzando i prefissi PE e PA. Questa modalita di
accesso agli /0 viene spesso utilizzato allinterno di OB a tempo per controllare delle
grandezze critiche. In questo caso, perd, non si pud accedere al singolo bit, ma solo ai byte,
alle word oppure alle doppie word.

Torniamo, ora, ai blocchi di dati. A differenza dei blocchi di codice, questi non contengono
istruzioni, ma servono alla memorizzazione dei dati utente.

Esistono due tipi di blocchi dati e sono elencati in Tabella 3.

Le DB contengono dati che possono essere utilizzati da tutti i blocchi di codice. In altre parole
le DB contengono le variabili dichiarate dal programmatore.

La struttura di una DB globale viene determinata dall'utente e non dipende da nessun blocco
di codice, mentre la struttura delle DB d’istanza rispecchia la dichiarazione delle variabili dell’FB
a cui fa riferimento.

Quando si apre un blocco dati viene richiamato I'editor KOP, AWL e FUP e viene visualizzata
la struttura del blocco (vedi fig. 15).

Nella prima colonna, per ogni variabile, & riportato l'indirizzo interno al blocco di dati. Nella
altre colonne si devono inserire, rispettivamente, il nome del dato, il tipo, il valore iniziale e un
commento.

Quella mostrata in figura € la Declaration View ed € la visualizzazione che permette di editare
la struttura del blocco (per poter passare a questa modalita di visualizzazione basta selezionare
View->Declaration View).

All'interno di una DB si possono definire dei dati strutturati: nell’esempio in figura esiste una
struttura FrontiDiSalita, che non & altro che un record di bit, ognuno dei quali rappresenta il
fronte di un segnale d’ingresso. Il codice che genera questi fronti a partire dagli ingressi si
trovera in un blocco FC.
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Area di Dimensione Prefisso Area di Dimensione Prefisso

memoria del dato memoria del dato
Immagine di Bit E Blocchi dati Blocco DI
processo Byte EB diistanza Bit DIX
degli ingressi Word EW Byte DIB
Double ED Word DIW
Immagine di Bit A Double DID
processo Byte AB Stack dei Bit L
delle uscite Word AW dati locali Byte LB
Double AD Word LW
Area merker Bit M Double LD
Byte MB
Word MW Area Timer T
Double MD Area Contatori Z
Blocchi dati Blocco DB
globali Bit DBX
Byte DBB
Word DBW
Double DBD

Tabella 2 - Prefissi delle aree di memoria

Blocco Descrizione

Blocchi dati di istanza Le DB di istanza vengono assegnate al blocco
(DB di istanza) funzionale quando viene richiamato un FB
oppure un SFB. Essi vengono generati
automaticamente nella compilazione.

Blocchi Dati globali Le DB sono aree dati per la memorizzazione
(DB) dei dati utente.

Tabella 3 - Blocchi di dati

L'utente ha la possibilita di definire dei tipi di dati attraverso i blocchi UDT. Per inserire uno di
questi blocchi bisogna selezionare I'opzione Insert—->S7 Block->Data Type.
Una volta aperto, un blocco UDT & uguale ad una DB. Nella fig. 16 & un esempio di UDT.

15



L’ambiente di sviluppo STEP 7

ELADJSTL!FBD - [DB50 -- 851-SaltarsTESTATALCPU 414-2 DP[1]]

1F File Edt |nset PLC Debug Wiew Options ‘Window Help

D||=r| 8| 8| o zl@| oo cldal [S a0 e

. 3| [AreaD Indnomalia BOOL FALSE
+2.4| |AreaE_Indnomalia BOOL FaL3E
+2.5( |AreaF _Indnomalia BOOL FALSE
+2.6( |[AreaG Indnomalia EBOOL FALSE
+2.7| [sparezs BOOL FALSE
+3.0| [sparezs BOOL FALSE
+3.1| [sparez? EOOL FALSE
+3.2| [sparezs EOOL FALSE
+3.3| [sparezs BOOL FALSE
+3.4| [spare30 BOOL FALSE
+3.5| [spare3l BOOL FALSE
+3.6| [spare3z BOOL FALSE
+3.7| [spare3d BOOL FALSE
+4.0| [Frontilifalita STRUCT
+0.0 3ES EOOL FALSE
+0.1 3E9 EOOL FALSE
+0. 2 KaTlsg BOOL FALSE
+0. 3 KaTzz BOOL FALSE
+0.4 Segh_ 11 BOOL FALSE
+0.5 Seqd_11 BOOL FALSE
+0.6 Seqlo_11 BOOL FALSE

Figura 15 - DB, declaration view

ELAD!STL!FBD - [UDT1 - 851-SalkarATESTATAACPU 414-2 DP[1]]

i} File Edit Inset FLC Debug “iew Option: “window Help

w B EINENE R N e o e N

lddress Hame Tyne Start value Comment
0. STRUCT
+0.0( |Presenzalogica EOOL FALSE O=4zzen=za logica l=Presemn
+0.1| [Mizsionedccettata EOOL FiLLE
+0.2| [MissioneRifiutata EOOL FALSE
+0.3| |[Mis=zioneRichiezsta EOOL FALSZE 0= Missione non richiesta .
+0. 4| [inomaliaVuotoYuoto BOOL FLL5E
+0.5] [dnomaliaPiencPiena EOOL FiLRE
+0.6| [AnomalialocZinacc EOOL FALSE
+0.7| |PrezenzaFizsica EOOL FALSZE O=Indefinito 1=UdC present:
+1.0]| |hssenzaFisica BOOL TRIUE O=Indefinito 1=0Ud4C assente
+1.1| [ZonaIndutomatica BOOL FiL:E O=Indefinito l=Zona in aut
+1.2| [ZonaInManuale EOOL FiL:E O=Indefinito l=Zona in mam

Figura 16 - Tracking Position UDT
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Una volta definito un tipo di dati con un UDT, questo pud essere utilizzato all'interno di una
DB, oppure all'interno della sezione di dichiarazione variabili di un blocco di codice.
L’'UDTH1, per esempio, viene richiamato nella DB10 (vedi fig. 17).

ELADISTL!FBD - [DB10 - 851-SalktarhTESTATALCPU 414-2 DP(1]]

% File Edt |nset PLC Debug “iew Option: ‘wWindow Help
Oe2|3E| & 2w o] eldn| [a a0 oy

Type

0. STEOCT
+0.0( (TP ARRAY[O..200]
*44.0 "TrackingPosUDLT™
END_5TRUCT

Figura 17 - Track DB

Dalla dichiarazione si capisce che la DB10 contiene un array di 200 UDT1
(“TrackingPosUDT” € il nome simbolico che € stato associato allUDT1). Se si seleziona
View->Data View non verra piu visualizzata la struttura della DB, bensi i singoli dati accessibili:

ELAD!STLJFBD - [DB10 -- 851-SakarATESTATALMCPU 414-2 DP[1]]

{3+ Fle Edt |nzet PLC Debug View Options Window Help

D|2[3E] & &[ml@] o] sl [S s 20 w2

E

Hame Type Start value Actual value Corm
TP[O].Presenzalogica EOOL FALSE O=4z

TP[0O].Mizs=zionedccettata EOOL FALSE FLLRSE
TP[O].MissioneRifiutata EOOL FALSE FALSE
TP[O].MizzioneRichiezsta EOOL FALSE FALLSE 0=
TP[0O].AnomaliaVuotoVuoto EOOL FALRE FALLAE
TP[O].AnomaliaPienoPienn EOOL FALSE FALLSE
TP[O].hdnomalialocZinacc EOOL FALAE FLLAE
TP[O].PrezenzaFisica EOOL FALSE FALSE 0=TIn
TP[0].h=zzenzaFizica EOOL TRUE TRUE 0=In

| ol e Y e |
Lo R NS N I T T O TV O e ) e

Figura 18 - Data View

Questa modalita di visualizzazione & l'unica che puo essere utilizzata quando si € on-line con
il controllore oppure con il simulatore; in questo caso nell’ultima colonna viene mostrato il valore
istantaneo dei dati. Per poter andare on-line & sufficiente premere il pulsante oppure
selezionare I'opzione Debug—>Monitor.

Con l'opzione Edit->Initialize Data Block ( pulsante & ), invece, & possibile forzare i
valori iniziali nelle singole variabili che costituiscono la DB.
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3 - Linguaggi di programmazione S7

Ognuno dei blocchi di codice che abbiamo introdotto nel paragrafo precedente pud contenere
istruzioni in diversi linguaggi di programmazione.

Il software di base di STEP 7 mette a disposizione tre linguaggi di programmazione:

e KOP o LAD (schema a contatti); & un linguaggio di programmazione grafico
che consente all'utente di seguire in modo semplice il flusso dei segnali tra le
sbarre collettrici, i contatti, gli elementi complessi e le bobine.

e FUP o FBD (schema funzionale); anche questo & un linguaggio grafico e
rappresenta la logica mediante i blocchi dell’algebra booleana. Esso consente,
inoltre, di rappresentare funzioni complesse (ad esempio funzioni matematiche)
direttamente connesse a i blocchi booleani.

o AWL o STL (lista di istruzioni); &€ un linguaggio di programmazione testuale
vicino al linguaggio macchina. Nella maggior parte dei casi, quindi, c'é una
corrispondenza uno ad uno tra le istruzioni AWL e le operazioni che la CPU del
controllore esegue.

Questi tre linguaggi sono, rispettivamente, la versione Siemens del linguaggio a contatti, del
diagramma a blocchi funzionali e della lista d’istruzioni specificati dallo standard IEC 61131.

AWL, KOP e FUP consentono di scrivere blocchi di codice direttamente caricabili nel
controllore, senza dover effettuare alcuna compilazione.

In STEP 7 viene messo a disposizione anche I'SCL. Questo & un linguaggio testuale messo a
disposizione come software opzionale; I'SCL ha espressioni linguistiche simili al Pascal e
corrisponde al Testo Strutturato dello standard IEC 61131.

A differenza dei linguaggi precedenti, i sorgenti SCL vanno compilati prima di poter essere
caricati nel controllore.

Solo per funzioni molto semplici, in cui si € voluta sfruttare I'immediatezza di un linguaggio
grafico, sono stati utilizzati il KOP oppure il FUP.

Qualsiasi sia il linguaggio utilizzato all'interno di un blocco di codice, &€ sempre possibile
richiamare, al suo interno, altri blocchi scritti in un linguaggio diverso.

Nelle pagine che seguono, presenteremo 'AWL, il KOP, il FUP e I'SCL; nella sezione
dedicata al’AWL faremo alcuni cenni sull'architettura interna delle CPU S7.

3.1-AWL

Tra tutti i linguaggi di programmazione S7, 'AWL rappresenta quello piu vicino al linguaggio
macchina MC7 delle CPU S7.

Per questa ragione il codice sviluppato in AWL risultera ottimale sia per quanto riguarda
I'occupazione di memoria, sia per quanto riguarda il tempo di esecuzione.

Come tutti i linguaggi di tipo assemblativo, perd, la leggibilita dei programmi risulta
difficoltosa, sebbene I'editor AWL consenta di inserire vari tipi di commento nel codice.

A questo riguardo, si ricordi che l'unica vera istruzione disponibile in AWL per il controllo del
flusso di programma € il salto, ed € con il salto che il programmatore deve implementare le
scelte ed i cicli.
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Cenni sull’architettura interna delle CPU della serie S7

Accumulatori

L’architettura delle CPU S7 e basata su una struttura a doppio accumulatore.

| due accumulatori ACCU1T ed ACCUZ2 sono i due registri operando dell’ALU e consentono di
lavorare con byte, word e double word. In essi si possono caricare costanti oppure valori di
memoria, eseguire delle operazioni aritmetico/logiche e trasferire il contenuto in un’area di
memoria.

‘ ACCU1 ’:j ACCU2 ‘

1L 1I

ALU

Figura 19 - ALU e Accumulatori

In fig. 20 € riportata la struttura di un accumulatore.

31 24 23 16 15 87 0
Byte alto Byte basso Byte alto Byte basso
~— - '
Parola alta Parola bassa
Accumulatore (1 0 2)

Figura 20 - Struttura di un accumulatore

I meccanismo di gestione degli accumulatori & il seguente:
e un'operazione di caricamento, per esempio L (load), trasferisce il contenuto di
ACCU1 in ACCU2 e carica I'operando desiderato in ACCU1;
e un'operazione di trasferimento, per esempio T (fransfer), non modifica il
contenuto degli accumulatori (ad eccezione delle istruzioni TAR1 e TAR2);
e [operazione TAK scambia tra loro i contenuti degli accumulatori.

Reqgistro di stato
Il registro di stato & una word di cui vengono utilizzati solo i primi 9 bit; la struttura &€ mostrata
in fig. 21.

20 ) 2¢ 27 26 b 4 5 2 21 20
BIE| A1 | AD |OV | OS| OR | STA| RLC | /[ER

Figura 21 - Registro di stato delle CPU S7
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L’utente pud accedere ad alcuni di questi bit come operandi per le operazioni logiche.

Prima di illustrare il significato dei singoli bit della word di stato, descriviamo come, le CPU
S7, effettuano le operazioni logiche su bit.

Una catena di istruzioni logico/combinatorie in successione viene chiamata stringa logica;
ogni istruzione di una stringa interroga lo stato dell'operando e lo combina con il contenuto del
bit 1 della word di stato (risultato logico combinatorio - RLC). |l risultato dell'operazione viene
memorizzato ancora nel bit RLC.

Quando una stringa logica termina, ad esempio con un’istruzione di assegnazione, il valore il
bit RLC conterra il risultato di tutte le istruzioni.

L'unica eccezione a questa modalita di funzionamento riguarda la prima istruzione di una
stringa logica. In questo caso lo stato dell'operando viene trasferito direttamente nellRLC.

Il bit 0 (/ER) della word di stato viene chiamato bit di prima interrogazione e indica l'inizio di
una stringa logica; il suo funzionamento & in logica negata. E questo bit che permette di
riconoscere la prima istruzione di una stringa logica.

Se /ER vale 0 l'operando indirizzato in un’istruzione logico/combinatoria viene memorizzato
nel bit RLC, dopodicché il valore di /ER viene impostato ad 1.

Quando /ER vale 1 un’operazione logico/combinatoria combina il proprio operando con I'RLC;
il risultato viene memorizzato nellRLC stesso.

[ER viene rimesso a 0 alla fine di una stringa logica, cioé dopo un’istruzione di assegnazione,
oppure dopo un’istruzione di salto correlata al risultato logico della stringa, oppure con
un’espressione di annidamento.

Come abbiamo gia visto il bit 1, che viene chiamato risultato logico combinatorio, memorizza
il risultato di un’operazione logica o di confronto.

In fig. 22 € mostrato il comportamento dei bit /ER ed RLC quando viene valutata
un’espressione logica.

Programma | Stato di segnale | Risultato |Bit Bit /ER Spiegazione
AWL diingressi (E) o |interrog. |RLC
di uscite (A)

0 Bit /ER = 0 indica che l'operazione
/_‘\ successiva inizia una stringa logica
UE1D 1 1 1 Il risultato di prima interrogazione viene
memorizzato nel bit RLC. Il bit /ER
viene settato a 1.

UN E11 0 1 1 Il risultato dell'interr. viene combinato
con I'RLC preced., secondo la tabella
della verita AND. Il bit /ER rimane "1".

AR 1 0 L'RLC viene assegnato alla bobina di
. : uscita. |l bit /ER viene resettato a "0".

Figura 22 - /EO ed RLC
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L’RLC puo essere settato incodizionatamente ad 1 oppure a 0 adoperando, rispettivamente,
listruzione AWL SET oppure CLR.

In base al valore del’RLC si possono eseguire 0 meno operazioni di salto, utilizzando le
istruzioni di salto condizionato SPB e SPBN.

Il bit 2 della word di stato, STA - bit di stato, memorizza il valore di un bit a cui viene fatto
riferimento in una determinata istruzione.

Nel caso di istruzioni logico/combinatorie che accedono alla memoria in lettura, il bit STA &
uguale al valore del bit a cui si accede.

Per le istruzioni logico/combinatorie che accedono alla memoria in scrittura, il valore di STA &
uguale al valore scritto oppure, nel caso in cui la scrittura non abbia luogo, al valore
dell'operando a cui l'istruzione si riferisce.

II bit di stato non ha significato per le operazioni logico/combinatorie che non accedono in
memoria.

II' bit 3 viene chiamato bit OR.

Questo bit ha un significato solo nelle stringhe logiche in cui siano presenti operazioni di AND
prima di operazioni di OR. In questo caso il bit di OR indica se una funzione AND, eseguita
prima di una OR, ha fornito valore 1, anticipando cosi il risultato dell'operazione di OR.

Il '5° bit della word di stato ¢ il bit di overflow (OV) e indica un errore. OV viene messo a 1
dopo che si & verificato un errore in un’operazione matematica oppure in un’operazione di
confronto in virgola mobile.

II bit successivo € il bit di overflow con memoria (OS); questo bit viene messo a 1 assieme a
OV quando si verifica un errore.

Mentre OV viene resettato quando si effettua una nuova operazione, OS rimane ad 1 anche
dopo il verificarsi dell'errore, quindi mantiene memoria del verificarsi di un errore in una delle
operazioni precedenti.

I comando AWL SPS (salta se OS=1) e i comandi di richiamo blocco e di fine blocco
resettano a 0 il valore di OS.

| bit 6 e 7 della word di stato vengono chiamati bit di visualizzazione A0 e A1 e forniscono
informazioni sull'esito di alcune operazioni. Per esempio, in base al valore di questi due bit si
puo conoscere se il risultato di un’operazione matematica € minore, maggiore oppure uguale a
zero, oppure si puo risalire al valore del bit traslato in un'operazione di shift.

L’ultimo bit della word di stato a cui & associato un significato & il bit di risultato binario (BIE).

Il bit BIE rappresenta un merker interno alla macchina, in cui viene salvato 'RLC prima di
un’operazione che ne modifichi il valore (per esempio un’espressione annidata). Dopo
I'operazione, grazie a BIE, & possibile ripristinare il valore dell’RLC e continuare la stringa logica
interrotta.

Registri indirizzo
Nei controllori della serie S7 sono presenti due registri indirizzo AR1 e AR2, che vengono
utilizzati delle operazioni di indirizzamento indiretto dei dati.
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31.. .24 23.. 16 15.. 8 7. 3.0
0000 0000/0000 0 bbb| bbbb bbbb|bbbb b xxx|

Bit 31 = 0 per indicare l'indirizzamento indiretto di registro, interno all'area

Da bit 3 a bit 18 (bbbb bbbb bbbb bbbb): numerco di byte (da 0 a 65 535) del
byte indirizzato

Da bit 0 a bit 2 (xxx): numero di bit (da 0 a 7) del bit indirizzato

Figura 23 - Formato puntatore

In questi registri & contenuto un dato di tipo puntatore il cui formato € illustrato in fig. 23. Una
costante di tipo puntatore si specifica con il prefisso P#.

Un esempio di utilizzo dei registri AR1 e AR2 per un puntamento indiretto & l'istruzione L
EBJ[AR1,P#100.0], che carica in ACCU1 il byte d’ingresso il cui indirizzo si ottiene sommando
100 byte al contenuto di AR1.

Registri blocco dati

Quando si utilizzano operandi contenuti in un blocco di dati, il numero della DB a cui si
accede viene memorizzato nel registro interno DB1.

Quando si vuole accedere a piu dati all'interno di una stessa DB, si pud specificare solo
lindirizzo interno al blocco utilizzando il comando AWL AUF che carica in DB1 il numero della
DB da aprire.

Esiste anche un secondo registro DB2 in cui viene memorizzato il numero della DB di istanza
alla quale si sta accedendo.

Istruzioni AWL e sorgenti

L’AWL di STEP 7 mette a disposizione un ampio set di istruzioni; abbiamo:
e operazioni logico/combinatorie su bit, su word e doppie word;

timer e contatori;

operazioni di caricamento e trasferimento;

operazioni matematiche su numeri interi ed in virgola mobile;

operazioni di confronto;

operazioni di conversione tra tipi diversi;

operazioni di scorrimento;

operazioni per la manipolazione delle DB;

operazioni di salto;

altre operazioni per il controllo del flusso di programma (per esempio chiamata

condizionata di un FC/FB, MCR)

Tutte le istruzioni AWL possono essere suddivise in due gruppi: istruzioni senza operando ed
istruzioni a singolo operando.

L’operando pud essere una costante, oppure un indirizzo in cui l'istruzione trova un valore.
L’operando, inoltre, pud essere specificato sia attraverso l'indirizzo, sia attraverso il nome
simbolico.
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Per poter editare il codice AWL in un blocco di programma, bisogna aprire il blocco ed
assicurarsi che il codice scritto venga visualizzato in AWL (selezionare View->STL nell'editor
KOP/FUP/AWL).

STEP 7 consente di convertire il codice scritto da un linguaggio ad un altro, semplicemente
selezionando il linguaggio di visualizzazione nel menu View.

Questa conversione & sempre possibile se si vuole passare da KOP ad AWL o FUP, oppure
da FUP ad AWL o KOP.

La conversione da AWL a KOP o FUP, invece, non & sempre possibile: I'editor riesce
nell'operazione solo per segmenti di codice semplici.

Con I'editor AWL, KOP e FUP, selezionando I'opzione File—>Generate Source..., € possibile
generare i sorgenti dei blocchi scritti in uno di questi tre linguaggi. Bisogna notare che qualsiasi
sia il linguaggio di partenza, si ottiene sempre un sorgente AWL.

Un sorgente € un documento in formato testo che pu6 essere salvato in un file esterno al
progetto (Edit->Export Source...). E possibile, quindi, creare una libreria di funzioni da
riutilizzare in progetti diversi.

A TIC Manager - [B51-5altan -- DASIEMENSAS TEPZAS Fproji 851 pic]

[ a1® |nzert PLC Wiew Options Window Help

: Cut Chrl+
H Copy Chrl+C
tf Easte (S| Object name | syrt
i Allarmiluadio_Gen.. -
[ Deete Dl AllarmiStatiPerSyD...
Select Al Chrl+d, AllarmiStatiPerSyLL ..
Unda Selection Alarri_Statitaces...
_ _ Allarmi_StatiMacchi...
[ Object Properties. .. Llt+Return B
Special Object Properties b DoSeache
U=l Ltrl+Alt+0 DBStampante
Compile Chl+B G estionel mpilatore
INTERFALCCIASYM. . -

|ncangruenza_PLD... -
InterfacciaSyaMSG... -
MizgioneTraslolJDT... -
B Statifuadro_Gener...
Yalor_ReportDB

Figura 24 - Esportare un sorgente

Per poter inserire un sorgente esterno all'interno di un progetto & sufficiente aprire la cartella
Sources del programma S7 e selezionare Insert—>External Source.... Una volta importato il
blocco sorgente questo va compilato per ottenere il blocco eseguibile, selezionando
Edit->Compile in SIMATIC Manager oppure File—>Compile nel menu dell'editor.

3.2-KOP e FUP

Il linguaggio a contatti (KOP) e quello a blocchi funzionali (FUP) sono i due linguaggi grafici
integrati nel software di base di STEP 7.
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Nel KOP le funzioni booleane vengono rappresentate attraverso la logica a relé, mentre il
FUP mette a disposizione direttamente dei box che effettuano le operazioni logiche.

Entrambi i linguaggi permettono di realizzare anche operazioni complesse come le
operazioni matematiche, le chiamate di FC e I'utilizzo di temporizzatori e contatori.

In questo modo l'utente KOP/FUP ha a disposizione tutti gli elementi necessari per creare un
programma completo.

Solo per quanto riguarda il KOP, I'editor prevede una limitazione: ogni rung deve essere
scritto in un segmento di codice (network) diverso .

Nelle figure 25 e 26 vengono mostrati due esempi di codice KOP e FUP.

P

]
:ﬂetwurk 64_:: Uzscita elettrovalwola W4 - chiusura pinze IPOL

Comment:
E
"Comandodi
tomatico™.
W —
"IbZona_1"
Zonalndut =
omatico — —
Er
"Comandola
niale’™ . ¥V ——
"IhZona_1"
ZonalnMan &
uale — — —
"Dbh3tatiZo
nal™.IP0L.
Macchinaln
Avaria =1
"DhZona 17 VA"
.ZonalnEne =
FOEnEa =1 —
Figura 25 - Segmento di codice FUP
3.3-SCL

L’SCL & un linguaggio testuale di alto livello per la programmazione dei sistemi di controllo
S7.

Le espressioni linguistiche e la sintassi del’' SCL sono simili a quelle del linguaggio Pascal.

Con I'SCL si possono creare OB, FC, FB, DB e UDT.
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Hetwork 15 : Uscita motore rulliera TROG spostamento a destra

Conment:
"Dh3tatiZo
"Conandodu  “"DbZona 1™ nal™.TRO6. "Dhiona 17
tomatico™. .Zonalndut MacchinalIn .ZonalhEwme
ula omatico Avaria rgenza TEME™
| | | | | 2 | 2] T |
1 11 L/)I L/)I L ]

"IbZona 1"
"ComandoMa .ZonalnlMan

miale” . EMe uale

Figura 26 - Rung in linguaggio KOP

Per poter inserire in un programma un sorgente SCL, bisogna aprire la cartella Sources in
SIMATIC Manager e selezionare I'opzione Insert->S7 Software—>5 SCL Source.

A questo punto comparira, nella parte destra di SIMATIC Manager, I'icona del blocco inserito;
aprendo questo blocco viene richiamato I'editor SCL.

Questo editor permette di inserire i template dei vari blocchi di programma (OB, FC, DB, ecc.)
mediante il menu Insert->Block Template. Per esempio, se si inserisce la maschera per un
FC, l'editor provvede a scrivere automaticamente le intestazioni delle varie parti del blocco
(dichiarazione della variabili, blocco istruzioni), cosi come mostrato in fig. 27.

Per default, I'editor inserisce una funzione che restituisce un intero e prevede solo il blocco
per i parametri temporanei. Se si vogliono inserire anche i parametri di I/O o le costanti basta
selezionare rispettivamente Insert->Block Template—>Parameter oppure Insert—>Block
Template—> Constant.

Una volta completato un blocco in SCL, questo va compilato per poter generare il blocco
esequibile.

Nella maggior parte dei casi, quando si compila un blocco SCL, il codice eseguibile ottenuto
occupera uno spazio maggiore di memoria rispetto ad un blocco AWL che realizza le stessa
funzione.

A volte, per codici molto complessi, questa differenza pu6 raggiungere anche un fattore dieci.
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E%'l' SCL - [SequenceDKFC = -- 851 - Salkari\TESTATAMCPU 414-2 DP]

File Edt Ingert PLC Debug Miew DOption: Window Help
T = s R 1 e s e A = (=
® |#%| e o5 2] 5 i

FUNCTION FCxxx: INT

VAR TEMP
¢ Temporary Wariables

END_VAR

BEGIN
~# Code Section

FCHHH:= 100;
END_FUNCTION

Figura 27 - Blocco FC in SCL

Va detto, perd, che, per funzioni molto complesse, anche un programmatore esperto di AWL

spesso giunge ad una soluzione poco leggibile e, quindi, di difficile interpretazione da parte di
un altro programmatore.

Quando si compila un sorgente SCL bisogna assicurarsi di aver gia compilato tutti i blocchi,
sia codice che dati, richiamati al suo interno, altrimenti il compilatore dara un errore.
Il Make File pud essere utilizzato per facilitare la compilazione di piu blocchi SCL. Per inserire

questo file nella cartella Sources basta selezionare Insert->S7 Software—>6 SCL compile
control file.

QSIHATIE Manager - [B51 - Saltan -- D:ASIEMENSAS TEPAAS Fprojinew]
% Eile Edit Inzet PLC “iew DOptions Window Help
a5

el =2 e A e T T  ERE N

B 851 - Saltai =

=-E TESTATA @
- [@ cPu 4142 0P

i [E-{z7] Programma 57

- CP 4431

Figura 28 - Make File

Il Make File & un file testo in cui vengono scritti i nomi dei vari sorgenti SCL da compilare. La
successione con la quale avviene la compilazione e quella in cui vengono scritti i nomi dei

blocchi. Per evitare errori di compilazione, allora, € conveniente strutturare il Make File nel
modo seguente:

1. compilazione degli UDT;
2. compilazione delle DB che utilizzano UDT;
3. compilazione delle DB globali;
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4. compilazione di FC ed FB, facendo attenzione alla successione in con cui
queste vengono compilate (se FC1 viene richiamato in FC2 va compilato prima
FC1 e poi FC2) ;

5. compilazione delle DB di istanza;

6. compilazione degli OB.

Se si desidera, si possono inserire piu blocchi di programma S7 nello stesso sorgente SCL.
La sequenza con la quale i vari blocchi vanno scritti deve rispecchiare le stesse regole con le
quali avviene la compilazione dei sorgenti.

Con le istruzioni messe a disposizione dall’SCL si possono valutare in maniera agevole
espressioni aritmetiche e logiche anche molto complesse.

Le istruzioni di controllo sono quelle tipiche del Pascal, cioé la scelta (IF, THEN, ELSE e
CASE), i cicli (FOR, WHILE e REPEAT) e il salto (GOTO).

L'utente ha a disposizione anche istruzioni particolari, tipiche dei linguaggi per i controllori, per
la gestione dei temporizzatori e dei contatori.

In maniera analoga a quanto visto per i sorgenti AWL, & possibile esportare ed importare da
file esterni anche i sorgenti SCL.

3.4 - Indirizzi e nomi simbolici

Con STEP 7 ¢ possibile assegnare dei nomi simbolici ai vari blocchi di programma ed agli
operandi in memoria; in questo modo si aumenta notevolmente la leggibilita del codice prodotto
e viene facilitato il debug.

Allinterno di un blocco S7 ¢ possibile riferirsi ad un altro blocco o ad un operando sia con
lindirizzo assoluto, sia con il simbolo.

Con l'editor AWL, KOP e FUP, l'utente pud scegliere se visualizzare gli indirizzi assoluti
oppure i simboli, selezionando I'opzione View->Display with->Symbolic Rapresentation o
agendo sul pulsante . EI

In un sorgente SCL, invece, possono essere visualizzati contemporaneamente sia
gli indirizzi che i simboli, cosi come vengono digitati dal programmatore.

Per poter fare I'assegnazione indirizzo->simbolo, bisogna aprire I'oggetto Symbols nella
cartella Programma S7:

'Ei"‘ 851 - Saltani -- DASIEMENSASTEP?AS Pprojinew

=-£E8 851 - 5 altai
= TESTATA @

=-[@ crus1420P S e s
. -3 Programma 57 ot i

(B Sources

m-fff CP 44341

Figura 29 - Symbols

SIMATIC Manager richiama I'editor dei simboli, un’applicazione simile ad un foglio di calcolo:
nella prima colonna bisogna inserire il simbolo, nella seconda l'indirizzo assoluto al quale il
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simbolo si riferisce, nella terza il tipo dell'operando o del blocco e nella quarta colonna si pud
inserire un commento.

Fﬁ_‘;ﬁymbul Editor - 851-Saltaris\TESTATAMCPU 414-2 DP(1__.ASimboli

Symbaol Table  Edit  Inzert Wiew Optionz  wWindow  Help

Z|d| S| & ofc] [asmbos =1%| K2
&j 851-Saltari\TESTATACPU 414-2 DP[1.._.ASimboli
Symbol Address Data type Comment
AbilAutomatichelonal DB 54 DB 54
AbilAutomatichedona? DB G4 DB B4
AbilAutomatichedonak DB ¥4 DB 74
AbilitazionitanualiDB DB 97 LUDT 3

AbilitazbovimAutom. fonal FC 54 FC 54

AbiltazMovimAutom. fona2 FC B4 FC B4

AbiltazMovimAutom. fonak FC 74 FC o 74

Aggiornalntimpilatore FC 226 FC 226 Aggiorna la Db dinterfaccia dellimpilatare
9 |Allarmi&statiMacchinasy UDT B UDT B Allarmi&StatiMacchinaz'y

10 | AllarmidstatiMacchspecDE DB 246 DE 246

(==HE N A=, RN S R

11 | Allarmi. StatiCluadro FCoo42 FC 42

12 | AllarmiMacchinalldT uoT 4 uUDT 4

13 | AllarmiMacchine. Lonal FC 82 FC &2

14 | AllarmiMacchine. £Zona2 FC B2 FC B2

15 | AllarmiMacchine. Zonab FC 72 FC 72

16 AllarmiQuadro&GeneraliDE DB 241 DB 241

17 B E 21.0 BOOL Fresenza UdC su TR O1

18 |B10 E 223 BOOL Presenza UdC su trasportatore TC 47

Figura 30 - Symbol Editor

STEP 7 permette anche di editare i simboli utilizzando Excel, salvando il file in formato .dif;
per poter importare il file con l'editor dei simboli basta selezionare l'opzione Symbol
Table—>Import.... In maniera analoga, con Symbol Table—>Export..., &€ possibile salvare in
un file esterno al progetto, i simboli utilizzati.

Anche con l'editor AWL, KOP e FUP si pu6 assegnare un simbolo ad un indirizzo assoluto,
selezionandolo e utilizzando 'opzione Edit->Symbols....

Vediamo, ora, cosa succede in un programma S7 quando si cambiano alcuni nomi simbolici.
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Supponiamo di effettuare i seguenti cambiamenti:

Prima Dopo
Nome Simbolico Indirizzo Assoluto Nome Simbolico Indirizzo Assoluto
B23 E0.0 B45 E0.0
B45 E0.1 B23 E0.1

Se in un segmento di codice AWL, per esempio, € presente l'istruzione:
U “B23”
quando si effettua il cambio del nome simbolico possono succedere due cose:
1. leditor assegna una priorita maggiore all'indirizzo assoluto, quindi nel codice
troveremo listruzione U “B45”, perché si fara sempre riferimento allingresso
E0.0.
2. L'editor assegna una priorita maggiore al nome simbolico, quindi nel codice
listruzione rimarra U “B23", ma in questo caso viene fatto riferimento
allingresso con indirizzo E0.1.

Properties - Block folder offline E3

General Blocks I Ehecksumsl

— bemaor
Size in load memarny: 28078 buytes
Size in work memony: Code A738 bytes
[ata 134 bytes
Tatal 872 bytes
— MNumber of Blocks
0B: 1 SFE: 1]
DB: 1 SFC: 0
FE: ] UoT: 1]
IFIE: B WAT: 0
@ss pricrity: Abzolute value j\
Abzolute value |
[ ek | Cancel | He

Figura 31 - Blocks->Object Properties

E possibile scegliere se dare una prioritd maggiore ai nomi simbolici oppure agli indirizzi
assoluti selezionando la cartella Blocks e I'opzione Edit->Object Properties... (vedi fig. 31).

3.5 - Il simulatore di controllori S7-PLCSIM e le tabelle di variabili (VAT)
Il simulatore di PLC permette di testare i programmi scritti anche quando non & disponibile un
controllore reale da collegare al PC.

E possibile avviare S7-PLCSIM dalla cartella Simatic=>STEP 7 del menu avvio, oppure
premendo il pulsante in SIMATIC &m| Manager.
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Una volta avviata I'applicazione si ha a disposizione un vero e proprio PLC Siemens:

ES?-PLESIH - SimYiewl

Simulation  Edit  lnzert PLC  Execute
D|=|=| J%IIEI = 1=l

DE'T-'SF. W STOP MRES

Figura 32 - S7-PLCSIM

Per poter testare il codice, quindi, questo deve essere prima caricato nel controllore
selezionando la cartella Blocks e 'opzione PLC->Download oppure il tasto .
Una ﬂl volta mandato in run il PLC & possibile visualizzare i blocchi di programma S7 in
modalita on-line.
E in questo modalita che & possibile vedere i valori attuali dei parametri all'interno delle DB.
Per i blocchi di codice, la modalita on-line permette di visualizzare il valore contenuto nei
registri interni del processore in corrispondenza di ogni istruzione eseguita:

HKLAD!STL!FBD - [(®FC53 -- 851-5altariATESTATANCPU 414-2 DP(1]] DMLIME
i} File Edit Inget PLC Debug “iew Options “Window Help

] =2 L I 1= =Y R e 1 e o e R e e i 53 =

Metwork T: POS[1] - TROL j| | RLO | STA | STANDARD | DEL |
Comment: Hide
Show »

/#==Presenza Fisica Dividing Lines

u "Bl I} ] o --

= "Track”.TP[1l].PrezenzaFizica 0 1] 0 10
fi==Azsenza Fisica

unly "E17 1 1] I} 10

= "Track".TP[1].Azsen=zaFisica 1 1 0 10
f/==Pozizione in Automatico

u "DhZona_ 1", Zonalnfdutomatico 0 0 of 30

= "Track™.TP[1l].Zonalndutonatico 1] 1] 0 10
fi==Posizione in Marmale

u "DhZIona 17, ZonalnManuale 1] L} of 50

= "Track".TP[1].ZonalnMarnale 0 1] 0 10

Figura 33 - FC on-line
RLO ¢ il bit RLC del registro di stato, mentre STANDARD & ACCU1.
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Premendo il tasto destro nella finestra di destra compare un menu a tendina che permette di
aggiungere o rimuovere i registri di cui sui vuole visualizzare il contenuto; & anche possibile
scegliere la rappresentazione dei dati (binaria, esadecimale, decimale, ecc.).

I simulatore stesso mette a disposizione delle finestre attraverso le quali & possibile
visualizzare il valore dei parametri di una DB, dei temporizzatori, dei contatori, dei registri
interni, ecc. Per inserire queste finestre bisogna utilizzare il menu Insert oppure la barra di
pulsanti evidenziata in fig. 34.

Con il pulsante si ﬂl puo far eseguire al PLC uno scan alla volta.

Un altro strumento utile per la prova ed il debug dei programmi sono le tabelle di variabili
(VAT). Anche queste tabelle servono per visualizzare gli operandi in memoria.

ES?-PLESIH - SimYiewl

Simulation  Edit  Inzett PLC Execute “iew Option: ‘window Help

D[={E| £]%]=] Blm[=| ¥

CoC
CIRUM
CIsTOP

[~ sTOP MHESl

FEYACCUs & Status Word == B
—Accumulators — Status ‘word
, [rata Block. o 8 loF
[10 o o | e
2o 6 [T CCO
3|0 i
Logic Block SAC 4 [0 " Hex 4 [ os
1 IFE 53 IHEE —a&ddresz Registers 3 Fg'?.-’-'-.
2o 1 8 -
| | L 1 I ALO
2 oo (1 =

Figura 34 - S7-PLCSIM, finestre di visualizzazione dei dati

Una volta inserita una VAT nella cartella Blocks, selezionando Insert->S7 Block—>6
Variable table da SIMATIC Manager, si potra aprire facendo doppio click sull’icona.

A questo punto verra richiamata I'applicazione Monitoring and modifying variables, che
visualizza la VAT come un foglio di calcolo nel quale & possibile inserire l'indirizzo della
variabile da visualizzare. Nelle altre colonne della tabella vengono riportati il simbolo della
variabile, il formato di rappresentazione, il valore attuale ed un eventuale valore da forzare (vedi
fig. 36).

Per poter forzare dei valori, bisogna collegare la VAT al PLC o al simulatore che esegue il
programma selezionando I'opzione PLC->Connect to, dopodicché bisogna passare on-line
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(Variable->Monitor), e forzare il nuovo valore premendo il pulsante oppure selezionando
Variable->Modify.

'Ei"‘ 851 - Saltari -- D:ASIEMENSASTEP?AS 7projinew

-2 851 - Saltarni
o[ TESTATA it
- [@ cPUs1420P 0E1
¢ [E-{z7] Programma 57
{E] Sources
LB Blocks D

m-ff CP 44341

Figura 35 - Tabella di variabili

Mentre con le finestre di visualizzazione del simulatore & possibile modificare i valori delle
variabili anche se il PLC & in RUN, per forzare un valore con una VAT bisogna assicurarsi che il
PLC sia nella modalita RUN-P.

Ricordiamo, infine, che non & possibile forzare i valori degli ingressi del controllore attraverso
le VAT. Esistono tre modi per modificare gli ingressi di un controllore: agire fisicamente sui
moduli I/0 della stazione, utilizzare il simulatore, oppure prevedere una funzione ad hoc che
vada a scrivere sull'immagine di processo degli ingressi.

e War - @VAT1

Table Edit |ngert PLC ‘“anable “iew Optionz Window Help

DB 8| & [=le]o] @l 2] 22| K| Sofar o] 659 w|

K2 @VAT1 - 851 - Saltari\TESTATA\CPU 414-2 DP OMLINE

IAddress |S?mhnl|HDnitDr FDrmﬁtlHDnitDr valuelﬂndif? valuel
DEED.DEW o - DEC a8 as
| 0.0 - BEIN 240

Figura 36 - Monitoring and modifying variables

32



L’ambiente di sviluppo STEP 7

Riferimenti

[1W‘1WM WWWw.ad.siemens.de/metazindex_76.nim, [sito ufficiale dei prodotti per I'automazione Siemens.

[2] SIMATIC S7 - Primi passi ed esercitazioni con STEP 7 V5.0, 6ES7810-4CA04-8EAQ, 1998 Siemens AG.

[3] SIMATIC S7 - Programmazione con STEP 7 V5.0, 6ES7810-4CA04-8EAQ, 1998 Siemens AG.

[4] SIMATIC S7 - Lista istruzioni (AWL) per S7-300/400, 6ES7810-4CA04-8EROQ, 1998 Siemens AG.
[5] SIMATIC S7 - Schema a contatti (KOP) per S7-300/400, 6ES7810-4CA04-8ERQ, 1998 Siemens AG.

[6] SIMATIC S7 - Schema logico (FUP) per S7-300/400, 6ES7810-4CA04-8ERO0, Siemens 1998 AG.
[7] SIMATIC - SCL per S7-300/400 - Programmazione di blocchi, 6ES7811-1CA02-8EAQ, 1998 Siemens.

[8] SIMATIC - S7-PLCSIM per testare i programmi S7, C79000-G7072-C201, 1998 Siemens.

33


http://www.ad.siemens.de/meta/index_76.htm

