RS Logix 500

RS Logix 500 [1] e il software applicativo della Rockwell Automation che permette di
sviluppare progetti d’automazione per i PLC Allen Bradley delle serie MicroLogix e SLC 500.

RS Logix 500 & un ambiente di sviluppo integrato e consente di:

o effettuare la configurazione hardware del controllore;

o effettuare la configurazione delle reti di comunicazione tra il controllore ed eventuali
/0 remoti presenti nel sistema di automazione;

e scrivere il programma utente;

e configurare la memoria del controllore programmabile;

e monitorare la memoria del controllore durante I'esecuzione del programma utente,
rendendo piu semplice il debug e la validazione.

L'unico linguaggio di programmazione messo a disposizione da RS Logix 500 ¢ il ladder.

RS Logix 500 permette, quindi, di gestire ogni aspetto dello sviluppo di software di
automazione per architetture basate su PLC Allen Bradley piccoli e medi.
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1 - Creazione di un nuovo progetto e configurazione hardware

Una volta installato RS Logix 500 sul personal computer, nella cartella Programmi del Menu
Awvio di Window comparira la sottocartella Rockwell Software, con tutti i link ai prodotti installati
ed alla documentazione in linea.
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Figura 1 - Nuovo progetto

Dopo aver mandato in esecuzione RS Logix, si selezioni File=>»New...1 per poter creare un
nuovo progetto. Comparira una finestra di dialogo attraverso la quale sara possibile scegliere il
nome del progetto e selezionare il modulo processore target (Figura 1). Il modulo processore
presente in laboratorio & un SLC 5/03 con 8 K di memoria (modello 1747-L531).

Dopo aver creato un nuovo progetto compariranno alcune finestre: sulla sinistra verra
visualizzata la struttura ad albero del progetto (project browser) mentre, sulla destra, comparira
I'editor ladder (Figura 2).
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Figura 2 - RS Logix 500

! nel sequito si usera la notazione File=>New... per indicare la selezione dell'opzione New...nel
menu File
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Oltre a queste finestre, in alto a sinistra & presente un menu a tendina (Figura 3) che
permette di gestire la modalita di collegamento tra il PC e il PLC e lo stato di funzionamento di
quest'ultimo (le stesse operazioni possono essere effettuate attraverso il ment Comms). In
particolare questo menu permette di selezionare la modalita di lavoro di RS Logix 500:
OFFLINE oppure ONLINE. Quando si lavora in modalita OFFLINE, tutte le operazioni che
vengono effettuate non hanno alcun effetto immediato sul programma eseguito dal controllore,
mentre in modalita ONLINE € possibile visualizzare il contenuto della memoria del controllore e
modificare il programma in linea.

H' RSLogix 500 - TEST
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Figura 3 - Modalita di funzionamento

Inoltre, se la chiave del modulo processore si trova nella posizione REM, utilizzando questo
menu € possibile modificare la modalita di funzionamento del PLC da PROGRAM a RUN
utilizzando RS Logix 500, senza dover intervenire fisicamente sul controllore programmabile.

Sempre attraverso questo menu, & possibile effettuare il download del progetto che si sta
sviluppando nella memoria del controllore, oppure I'upload del progetto che risiede attualmente
nella memoria del PLC per poter effettuare delle modifiche.
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Figura 4 - Configurazione hardware

La configurazione dell'architettura hardware del controllore a logica programmabile
rappresenta il primo passo nello sviluppo di un progetto d’automazione. Selezionando I'oggetto
I/0O Configuration presente nella cartella Controller del project browser, & possibile
selezionare il rack sul quale & montato il modulo processore, e specificare il numero ed il tipo di
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moduli addizionali presenti. Il controllore presente in laboratorio € montato su un rack a 7 slot
insieme ai moduli di I/O digitale 1746-1B16 e 1746-OW16 (Figura 4).
Oltre ad I/0 Configuration, nella cartella Controller sono presenti altri oggetti:
e Controller Porperties permette di modificare il modulo processore, modificare
Iinterfaccia di comunicazione tra I'host per la programmazione ¢ il target, ecc.
e Processor Status permette di monitorare lo stato del modulo processore e dei vari
data file presenti in memoria.
e Channel Configuration permette di configurare i canali di comunicazione tra il
modulo processore e I'l/O remoto.

Prima di poter iniziare a sviluppare un progetto d’automazione, € necessario configurare
I'interfaccia di comunicazione tra il PLC ed il PC.

La comunicazione tra il PC ed il controllore avviene attraverso il software di comunicazione
RS Linx. Per i PLC presenti in laboratorio la comunicazione avviene utilizzando il protocollo AB
DF1 su cavo seriale.

Se i driver di comunicazione sono stati installati correttamente, selezionando
Comms—>SysComms... € possibile configurare tutte le proprieta della comunicazione tra PLC
e PC (selezione del driver di comunicazione, indirizzi dei nodi sulla rete, ecc.).

Nel caso in cui i driver di comunicazione non siano ancora stati installati € necessario avviare
RSLinx e, attraverso il menu Communications—>Configure Drivers..., selezionare il driver
RS232 DF1 Devices.

Una volta completate tutte le operazioni di configurazione si € pronti per scrivere il
programma per il controllore.

2 — Program Files e Data Files

Un progetto di automazione per SLC 500 e costituito dall'insieme delle configurazioni della
piattaforma hardware, dai programmi e dai dati definiti dall'utente.
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Figura 5 - Program Files e Data Files

Nel project borwser sono disponibili due cartelle, Program Files e Data Files, che
contengono, rispettivamente, tutti i programmi e tutti i file di dati appartenenti ad un progetto
(Figura 5).

4 ultima revisione 22 marzo 2004



Quando si apre un progetto nuovo, nella cartella dei programmi compaiono tre file: i primi due
sono file di sistema e non possono essere modificati dall'utente. Il terzo (il cui nome di default &
LAD 2) e il programma utente. Selezionando I'opzione New... nel context menu della cartella
Program Files e possibile aggiungere altri file. Per i PLC della serie SLC 500 e possibile
aggiungere fino a 256 programmi utenti.

Il program file 2 rappresenta il main dell'applicazione ed € l'unico file che viene sempre
eseguito dal controllore. Attraverso I'utilizzo delle istruzioni JSR (Jump to Subroutine) e SBR
(Subroutine) e possibile richiamare altri program file o loro porzioni.

Nella cartella Data Files vengono visualizzati tutti i file presenti in memoria ai quali il
programmatore pud accedere. Oltre ai file relativi agli ingressi ed alle uscite del PLC
(rispettivamente | e O), sono presenti i file:

e S - file di stato del processore; attraverso questo file € possibile accedere allo stato
del modulo processore (per esempio al bit di prima scansione, oppure al bit di
overflow).

B - file interno binario;

T - file dei timer interni;

C - file dei contatori interni;

R - file di stato per istruzioni speciali; contiene alcune informazioni relative a
particolari istruzioni come le operazioni di registro a scorrimento.

e N -file interno di interi;

e F-file interno di floating point.

Questi 9 file rappresentano i file di default. E possibile aggiungere altri file utente (fino ad un
totale di 255), potendo specificare anche il tipo di dati contenuti (bit, interi, floating point, ecc.),
selezionando New... nel context menu della cartella Data Files nel project browser.

L'indirizzamento di un elemento all'interno di un file dipende dal tipo di file al quale si vuole
accedere. Per esempio per i file di I/O (file | e O) la sintassi é:

NOMEFILE : SLOT.WORDOFFSET / BIT
Si noti che le sia gli offset delle word che i bit vengono numerati a partire da 0; per esempio:
e 0:2.0/2 >terzo bit della prima word del modulo d'uscita nello slot 2.
Per una trattazione esaustiva delle modalita di indirizzamento si rimanda a [2].

Per poter rendere piu leggibili i programmi scritti in ladder & possibile associare dei nomi
simbolici alle variabili presenti nei vari file. Questa operazione puo essere effettuata in piu modi:

e assegnando un nome nel campo Symbol presente nella finestra di visualizzazione dei
file; € possibile accedere a questa finestra effettuando doppio-click sul file desiderato
(Figura 6).

e intervenendo direttamente nel diagramma ladder assegnando un nome simbolico alle
variabile gia utilizzate (Figura 7).
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Figura 7 - Assegnazione di nomi simbolici nel diagramma ladder

E possibile accedere ad un database contente i tutti i nomi simbolici utilizzati nel proprio
programma selezionando l'oggetto Address/Symbol allinterno della cartella Database nel
project browser (Figura 8).
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Figura 8 - Database dei simboli
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3 - L’editor Ladder

L'editor ladder permette di editare sia graficamente (utilizzando drag & drop) che in modalita
testuale i programmi utenti utilizzando il linguaggio a contatti dei controllori Allen Bradley.

Graficamente € possibile selezionare un'istruzione dalla barra degli strumenti e trascinarle sul
rung nel quale la si vuole inserire.

Nella barra degli strumenti le varie istruzioni vengono suddivisi per categorie; utilizzando il

pulsante E invece, viene aperta una finestra in cui vengono visualizzate tutte le istruzioni
(Figura 9).

E possibile accedere ad un help in linea delle varie istruzioni ladder selezionando Help=>SLC
Instruction Help.

Instuction Palette
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Figura 9 - Instruction Palette

In particolare, per aggiungere nuovi rung utilizzando il pulsante "= mentre per aggiungere un
branch all'interno di un rung gia esistente si deve utilizzare il pulsante .

Ogni qual volta si inserisce una nuova istruzione allinterno di un programma ladder, I'editor
marca il rung con una lettere “e”. Questa label indica che il rung é stato editato ma non ancora
validato. Per effettuare la validazione e la verifica degli errori dei singoli programmi € sufficiente

selezionare Edit->Verify File, oppure utilizzando il pulsante & nella barra degli strumenti. E
anche possibile effettuare la validazione dell'intero progetto selezionando Edit->Verify
Project, oppure utilizzando il pulsante =)

Quando si lavora in modalita ONLINE (selezionando Comms—>Go online), I'editor permette
di visualizzare il valore delle variabili utilizzate nei vari programmi ladder. E possibile, inoltre,
modificare “a caldo” il programma, cioé quando il PLC é in RUN. In questo caso le variazioni
apportate vengono marcate attraverso le label “i”, “r” e “d”, rispettivamente quando € stato
inserito, modificato oppure cancellato un rung. Per poter testare queste modifiche bisognera
prima accettare le modifiche selezionando Edit->Accept Rung (dopodicché le label
diventeranno maiuscole); successivamente si possono testare le modifiche selezionando
Edit->Test Edits. Se, infine, si desidera di rendere permanenti le modifiche fatte & sufficiente
selezionare Edit->Assemble Edits.

L'editor ladder permette di inserire un titolo per ogni program file e dei commenti per ogni
singolo rung (Figura 10). Per poterlo fare basta evidenziare con il tasto sinistro il numero del
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rung dove si vuole inserire il commento € selezionare Edit Comment nel contenxt menu; per
inserire il titolo, invece, selezionare Edit Title. Questo strumento, insieme alla possibilita di
utilizzare i nomi simbolici delle variabili, di aumentare la leggibilita del codice.
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Figura 10 — Commenti all'interno del codice ladder

Facendo doppio click sul numero di un rung, infine, & possibile editare in modalita testo le
istruzioni contenute in un rung (Figura 11).
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Figura 11 - Editing testuale

Per una descrizione completa del set di istruzioni disponibili per i PLC della serie SLC 500 si
faccia riferimento a [2].
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5 - Esempio di programmazione

Lo scambio ferroviario

Si scriva un programma ladder per la gestione dello scambio ferroviario del tratto di linea
ferroviaria riportato in Figura 12. Le specifiche sono:

lo scambio puo essere impegnato da un solo treno alla volta;

la precedenza va data ai treni provenienti dal secondo binario (rail 2);

quando il treno che tiene impegnato lo scambio supera il rilevatore FREE, lo scambio
viene reso di nuovo disponibile;

se un treno passa con il rosso deve essere azionato I'allarme e bisogna aprire |l
sezionatore del relativo binario;

se un treno impiega pit di 5 minuti per attraversare lo scambio, deve essere azionato
Iallarme.

La lista degli ingressi e delle uscite € riportata in Tabella 1

RED1

GREEN1 @

SEZ1

ALARM

Rail 1 II RESET ALARM

Rail 2

A INL

MOV1

RED2

Figura 12 - Lo scambio ferroviario
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Tabella 1 - Ingressi ed uscite
Ingressi Uscite

R1 Richiesta impegno scambio da  RED1 Semaforo rosso al binario 1
parte del binario 1

R2 Richiesta impegno scambio da  RED2 Semaforo rosso al binario 2
parte del binario 2

IN1 Segnale di avvenuto impegno ~ GREEN1 Semaforo verde al binario 1
scambio da parte del binario 1

IN2 Segnale di avvenuto impegno  GREEN2 Semaforo verde al binario 2
scambio da parte del binario 2|

DN1 Segnale di avvenuto MOV1 Posiziona scambio in posizione 1
posizionamento dello scambio in
posizione 1

DN2 Segnale di avvenuto MOV2 Posiziona scambio in posizione 2
posizionamento dello scambio in
posizione 2

FREE Segnale di avvenuto disimpegno SEZ1 Sezionatore linea binario 1
del binario

RESET Reset dell'allarme SEZ2 Sezionatore linea binario 2

ALARM

ALARM Allarme
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Riferimenti

[1] RS Logix 500 — Getting Results Guide, LG500-GR0O01A-EN-P, 2002 Rockwell Automation.

[2] SLC 500 Instruction Set — Reference Manual; 2002 Rockwell Automation.
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